tleader

Regular Member
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tleader

  • Rank
    New Club Member
  1. I had the same problem when I first bought my 91 Ls 400. The traction light on the bottom of the cluster starts to blink when an engine code is present. You need to figure out what the engine code is, and then when you fix it, the light should stop blinking. My vehicle was giving a code 27, which is lean air-fuel mixture. I replaced the front O2 sensors and it cured the problem. The light no longer blinks. My advise is to but some manuals or CD's on ebay which will give you in depth info on codes and repair. They have fixed every problem I have encountered and saved me massive amounts of money and trips to the dealer. If you can do it yourself, stay away from the dealer at all costs.
  2. The easiest thing to do is go to a junkyard. Go to a pick n pull junkyard and get all the bulbs you need. You can get all of the bulbs off of any Toyota vehicle. All of the bulbs are the same, and easy to get to (not to mention, very cheap). Thats what I did, and everything works great now.
  3. The O/D light is flashingin my 91 LS400. The tranny seems to be working fine, with no mishaps. The O/D switch works, and when it is switched on, the light starts to flash, but the car DOES go into overdrive. I have not noticed any problems thus far, but according to the manual, it is saying there is a major transmission failure. Anyone got any ideas, or know if there is a sensor out? Could it be the beginning of a transmission failure? Any help would be appreciated.
  4. When I get on the freeway I start to feel a vibration in the rear of the vehicle at around 75 to 80 mph. I don't think that it is the wheels. I was wondering if it could be the driveshaft. Does the LS400 use u-joints in the driveshaft? If so, are they easily replaced. Does anyone have any other conclusions on the source of the vibration. Any help would be appreciated.
  5. Thanks for the clarification. I will look into getting an intake.
  6. Thanks, The reason I am asking is because they make intakes for 92-95 LS400's only. Why not 91'?
  7. I was wonder if the Injen intake for the 92 LS400 would work on the 91 model. I am not too sure what the difference is in the two years. Could anyone help with this? Also, is it possible to modify the 92 intake to work on the 91 engine and air sensor. Any help would be greatly appreciated.
  8. I was wonder if the Injen intake for the 92 LS400 would work on the 91 model. I am not too sure what the difference is in the two years. Could anyone help with this? Also, is it possible to modify the 92 intake to work on the 91 engine and air sensor. Any help would be greatly appreciated.
  9. I had the same problem with my 91' LS. I opted for the aftermarket coilvers to replace the air suspension. I have had no problems and cannot tell the difference, if fact it feels more solid. The whole kit was only 800.00 to my door. I would recommed this if you are tired of replacing the expensive air system.
  10. I am getting a code 25 on my 91 LS400 ecu. It say that it is a air-ratio lean malfunction. Anyone know how to fix this problem, or what cuold be causing it? Any help would be appreciated.
  11. I have the Nakamichi radio in my 91 Ls and only the right side sounds like it is playing to the full volume. The left side of the car is playing, but really low in volume. Anyone have any suggestions for a fix on this problem. Could it be the amp, and if so, where is it located. Thanks