SvpremeKai

Regular Member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About SvpremeKai

  • Rank
    New Club Member

Contact Methods

  • First Name
    Kasai

Profile Information

  • Lexus Model
    Lexus LS400
  • Lexus Year
    1993
  1. Hello everyone! I’m pretty new here, and before I ask my question, yes I’ve been throughout forums seeking answers and have tried a few things but now I feel as though I need advice. Recently grabbed a ‘93 LS400 that’s been misfiring. I just had the alternator and belt tensioner replaced but the car did stall out on me due to very rough and low idle. Check engine code comes up for the mass air flow sensor and TPS, both of which were replaced and recently adjusted by my mechanic. I had heard that if the catalytic converters were glowing red that means that they were possibly clogged, possibly oil in the cylinders leaking(?). I’m not sure, I’m fairly new to these vehicles in general. One thing to keep note of is, the check engine light is illuminated. When I give the car gas it shows major power loss, however halfway thru second gear the car starts to pickup/ maintain speed and the check engine light goes away. Once I come to a stop, or even let off the gas for a bit the CEL comes back. Complete stop brings the rough idle back. I did read that the ignition coils could be to blame as well. I changed the one dead center in the engine, but not the second one by the battery. My question is should I be weary of the cats? My plan was the yank them and simply straight pipe the car on back. However efficiency is all I want now considering I haven’t had time to even enjoy the car since I purchased it 😟 1993 LS400 188,114 Miles