Do Not Sell My Personal Information Jump to content

95 Ls400 Windows Don't Work


Recommended Posts


Windows work from each door but not from driver master control. Have tried lowering half way down and raising + holding.

Now thats a new one on me. I thought you were going to have a simple issue like a child lock turned on, but you are saying the driver's side controls will not operate the other windows. Yet the switch right at each door will operate the local window? I am presuming that the drivers side window is controllable from the drivers side switch? It is very unlikely that all of the master drivers side switches are bad but it is very possible that the wiring is loose or off of those controls or that a central connector feeding those switches has come apart. Wonder if someone was recently into the drivers side door panel?

Link to post
Share on other sites

i have 95 lexus ls400, after just my car washed my car is not starting and even it doesnt make any starting noise and also front heater light blinking. when i was washing my car engine was stop but the head lights were ON. i thought my battery drained because brake light was dim. i try to boost start with another car but all in vain...

plz help!

thanks

Link to post
Share on other sites

@lswolfe77, if you think it's the master switch, one is available here:

http://www.clublexus.com/forums/ls460-430-400-classifieds/613548-fs-parting-out-1997-ls400-gray-interior-parts-and-more.html

@M Xakir Kayani, since your issue is not related to this thread, you'll get better help is you start a new topic. However, if you washed your engine, you'll need to give it time to dry out. Did you cover the main electrical box with plastic? If not, open the cover to help it dry out. Gotta be patient.

Link to post
Share on other sites

i have 95 lexus ls400, after just my car washed my car is not starting and even it doesnt make any starting noise and also front heater light blinking. when i was washing my car engine was stop but the head lights were ON. i thought my battery drained because brake light was dim. i try to boost start with another car but all in vain...

plz help!

thanks

I agree that this should have been a new thread. However, I do not believe the OP washed his engine. Something is lost in the translation. I think "when i was washing my car engine was stop" means that the engine was simply shut off while washing the car. Not an engine cleaning. Correct M Xakir Kayani?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...