cosmicfireball

Regular Member
  • Content Count

    61
  • Joined

  • Last visited

Community Reputation

0 Neutral

About cosmicfireball

  • Rank
    Club Member

Profile Information

  • Lexus Model
    sc300
  1. Can someone tell me where this is located in the dash. Can one remove the radio unit and get to it for replacement. How much should it cost to have a mechanic uninstall old/install a rebuilt? Thanks
  2. Or whatever it's called...located under/inside the dashboard compartment. Radiator place traces non functioning to the relay for the air conditionar stating that the control module is not functioning properly..after pressurizing the compressor system and testing,I think,two other electric components in front of the control module. When I reported that sometimes when it's cold outdoors and after the car heats up and produces heat in the 'cabin' and then I perhaps will stop the car,shut it off and start again there will be no heat. Mechanic thought this was another example of defective module. Will charge something like $550 to take out the dash,pull the module to get rebuilt and re-install. Any comments/advice for this '92 sc300.standard with 137,000 miles and due for a timing belt change? Thanks
  3. Felt a horrible vibration at the rear end of my sc300 while driving recently, had it checked out and turns out the gears in the diff has gone bad. So i purchased a used diff same size and everything however i observed 3s inscriped on it while 3v is inscriped on the one that went bad. What does these inscription mean?

  4. Compressor won't kick in and I've been advised that the refrigerant pressure is too low. Would someone advise what is the first cost effective procedure I should follow. '92 SC 300 with the 'old' form of refrigerant which is evidently difficult to find. Would it be useless/harmfull to get an adaptor to use the current form of recharge refrigerant gas in mix that 'stuff' with what remains in the system? A mechanic advised that the new form of gas has smaller molecules which will escape through the hose system...which sounded bogus to me..he also said something about damaging rubber seals/gaskets with a mixture. Thanks for any advice
  5. Can someone direct me to information about the Sport Wagon..specs...comparisons to the other IS models&general/specific opinions about it. Thanks in Advance
  6. I MIGHT be hearing some slight thumping..but not sure if it's bad tire or wheelbearings. At what mileage should bearings be replaced/repacked. My '92 SC300 has 127,000 miles and this maintence hasn't been done. ALSO At what intervals should one change the transmission oil? Thanks
  7. I can't understand why/how Lexus screwed up to over torque those fixtures onto the feul line...everyone has trouble getting them off. Good for 200 thousand miles...I don't think so.......... Lexus dealers I've contacted refuse to replace them..........
  8. I think I need a new starter...sometimes turn ignition a dozen times and just hear click. Lights don't dim and have a new battery. Then after a number of attempts the '92 sc300 will fire up. On other days no problem...fires up on first attempt. I'm considering three choices for replacement of the starter: Approx. $130-140 for a rebuilt Denso(plus 'core'). Rebuilt by who knows who/where? Approx. $250 for a Denso Factory rebuild.(I'm sure they don't send old ones back to Japan) Approx. $250 for a New Weatherhill Industries that is reccomended highly for durability. Any comments/experiences/suggestions? Never heard of Weatherhill before...anyone know anything about thier products? Thanks in advance.....
  9. "92 SC300 is hesitating on starting. Turn the ignition switch on,with clutch depressed of course,and nothing happens,no sound/clicking or anything. After a couple of tries with no result and then turn on again and ignition occurs with no hesitation or funny sounds. This issue started when tempretures were well below freezing and occassional occurs in the 50's. Any guess's what this problem is...the start of the failure of the starter..or is there a solonoid set up on this vehicle? Thanks in Advance.
  10. Thanks and no it's not the handbrake. It's definitely related to acceleration and deacceleration. No electrical issues are apparant in any other 'systems'. ?
  11. My brake light on my '92 intermittedly comes on...I've noted that sometimes it lights up after I let up on the pedal when accelerating under normal driving. But sometimes it lights up when I gently accelerate. I've checked brake fluid level and it's OK....nothing seems to be blocking the screen. Any suggestions? Thanks in advance
  12. 101,000 miles and the cracks are not that bad....it's started to squeek a little and just put some belt dressing on it and it's quiet now...but I've been told these small cracks is the 'beginning' of a problem with the belt...
  13. Need a new Serpentine belt...Is it others opinions that one should only get a Lexus issued belt or will a high grade American made belt be sufficient for the long run?