mek88

Regular Member
  • Content Count

    31
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mek88

  • Rank
    Club Member
  1. I have 99 RX300AWD with 149000 Miles with original transmission & engine. @ 122K I replaced: starter, timing belt, drive belts, waterpump, camseals, crankseal I change my engine oil every 8000 miles using Mobil1 5w30 and transmission oil every 15000 miles using toyota type4 by myself Gas: Chevron-87 Never been to snow / offroad.mostly just Los Angeles traffic Hope someone with higher mileage can share their experience on the transmission of their RX300AWD Thanks mek88@yahoo.com
  2. Mine is a 99 RX300 AWD @ 136K-miles with original engine & original tranny. I always use mobil-1-5w30 every 5K, and toyota type-IV-ATF every-15K. Does front differential & transmission share the same filling hole for ATF? So far I only changed the ATF for tranny by opening the drain bolt at the bottom of black-color ATF pan. I've never changed the front diff oil because I'm not sure how to fill it up. And I;ve never dropped the pan at all, never had any flush at all. Shall it fill it up all the way to whatever amount drain from tranny+diff at once from tranny filler(approx 5 qt of T-IV)? I'm just affraid if I drained them & fill them up, the ATF takes a while to circulate into Diff. On the meantime diff doesn't get lubricated after few miles or until it filled up. Please advise. Thanks email: mek88@yahoo.com in Los Angeles
  3. Can someone give me a mechanic reference for timing belt change on my 99 RX300AWD with 120K. I live in Los Angeles 91030. How much would it cost approximately including timing belt, waterpump, 3 seals, 2 serpentine belts,tensioner? Thanks mek88@yahoo.com
  4. I just changed the tranny oil few weeks ago. When I filled it up, I use the dipstick as a barometer(with engine not running). So I filled it up with only 1.75 qt of Type IV instead of 4qt as suppose to be. Yesterday morning, I checked it again with engine running when it was cold: It was right on the middle of the cold range. Then Yesterday afternoon, I checked it again with engine running after 30 miles trip, It was right on the middle of the hot range. So, I assume the fluid level is okay now. Problem: When I drive slow 25-30mph,and would like to accelerate, It doesn't downshift. It stays at the 4th gear, unless If I kicked my pedal to the floor then 2 sec later it shifted down. Appreciate any advise/comments. Thanks so much Mek88@yahoo.com in Los Angeles
  5. I was not aware that checking the transmission fluid require the engine to be running. As a result, yesterday my car suddently not moving, altough engine rev up. I switched the gear from P to N to R, then N, then P. It moved. Later I drove it for 40 miles, no problem. After realizing to check the fluid with engine running, that evening, I checked the level again With hot Engine after 30 miles drive, the level is below the "LOW" mark. I Put 1.25 quart of Type IV. Have I destroying my tranny? This is 99 RX300AWD with 120k Miles. I drive it with gentle. Thanks for advise. Email: Mek88@yahoo.com in Los Angeles
  6. Cracking noise/Rattle from driver side tweeter (dashboard speaker) My 99 RX300AWD creating cracking noise from driver side tweeter (dashboard speaker). When I pushed down the tweeter, the noise gone. I've tried to put some sort of rubberish shims around the gaps, but cracking noise still exist. Does anyone, has the procedures (or pictures) how to remove the tweeter on the dashboard? Thanks email: mek88@yahoo.com Los Angeles
  7. My 99 RX300AWD has 120K on original timing belt & waterpump. According to my friend who is a technician, he has seen some lexis with over 150K miles w/ original belt on it. He said that Lexus timing belt is wider compared to Honda's, and they're made stronger as well.
  8. Loud engine noise continue after key was pulled Desperately need help!! Yesterday, I drove my 99 RX300AWD (odo=110K miles) for 20 Miles with A/C off. Then, I parked the car for 2 hours. When I started the engine, there was a loud noise along with engine noise (sort of crane noise) Then, I shut the ignition off & pulled the key, engine shut off. However, that strange noise continue for approx 30 second (enough time for me to open the hood and trunk trying to get a wrench) Then, the noise completely gone by itself. I started the engine again & no more noise. I tried several times, and couldn't repeat the problem. Later, I drove the car for 100 miles, with a/c on & off. Nothing unusual. Trans oil&Engine oil level is fine. Could it be the starter keep engaging to the flywheel, or starter relay? If yes, why the noise continued for 30 sec after the key was pulled? Appreciate any suggestion. Email: mek88@yahoo.com Los Angeles
  9. Do you think I need to replace the idle air control valve? Could anybody tell me how to remove the throttle body (intake system) from RX300?
  10. My 1999 RX300-AWD has 105k Miles. When parked under the sun during summer (COLD ENGINE), I have to step on the gas pedal for 10-20 sec when starting the car. Otherwise the engine dies. I plug the scanner, and there is northing wrong. I also checked the relay, fuses, spark plugs, air filter and fuel pressure. Everything seems normal. Also, recently I notice more problems: after driving for a while, I stopped @ a store for 10-15 minutes, then the engine fail to start. I have to press the gas pedal for 10-20 seconds to keep the engine running. Anybody ever expreienced the same problems before? Please help me! Appreciate any comments/advises. Location: Los Angeles Email: mek88@yahoo.com
  11. I 'd like to upgrade my brand new RX330 for 19" for better looks. Do you guys know if I can put Enkei 19" and 8.5" width along with Falken 245/45/19? And I'm planning to sell my original set of 4: 18 inches silver wheels & tires(Goodyear Eagle RSA 235/55/18 with less than 200 miles,tires still have nubs on them). Asking $1000.00/obo I'm in Los Angeles, and I can ship it to lower 48 state of USA (HI & AK are excluded) Buyer pay shipping cost. Also, weekend or weekday-evening pickup is welcome. I'm in Los Angeles. My email is mek88@yahoo.com
  12. I just replaced my 2004 RX330 original 18" wheels, and upgraded for 19" wheels with no modification / no spacers needed. It handle better now, and same quitness. I'm selling the original RX330's 18 inches silver wheels & Goodyear Eagle RSA 235/55/18Tires with less than 200 miles (tires still have nubs on them) for $1000.00 I'm in Los Angeles, and I can ship it to lower 48 state of USA. Buyer pay shipping cost. Also, weekend or weekday-evening pickup is welcome. My email is mek88@yahoo.com
  13. I just replaced my 2004 RX330 original 18" wheels, and upgraded for 19" wheels with no modification / no spacers needed. It handle better now. I'm selling the original RX330's 18 inches silver wheels & Goodyear Eagle RSA 235/55/18Tires with less than 200 miles (tires still have nubs on them) for $1000.00 I'm in Los Angeles, and I can ship it to lower 48 state of USA. Buyer pay shipping cost. Also, weekend or weekday-evening pickup is welcome. My email is mek88@yahoo.com
  14. FOR SALE: 4 pieces of 18 inches silver wheels & tires comes from 2004 rx330. Tires are Goodyear Eagle RSA 235/55/18 with less than 200 miles (tires still have nubs on them). Asking $1000.00/obo I'm in Los Angeles, and I can ship it to lower 48 state of USA. Buyer pay shipping cost. Also, weekend or weekday-evening pickup is welcome. My email is mek88@yahoo.com
  15. I have 4 pieces of 18 inches silver wheels & tires comes from rx330 performance package. Tires are Goodyear Eagle RSA 235/55/18 with less than 200 miles. I also includes 16 lugs & 4 locks-lugs & 1-key Asking $1000.00/obo I'm in Los Angeles, I can ship them to Sacramento by fedex Ground for $80.00 (total is approx 160 Lbs), weekend/weekday-evening pickup is welcome. My email is mek88@yahoo.com