Faizmz

Regular Member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Faizmz

  • Rank
    New Club Member

Contact Methods

  • First Name
    Faiz

Profile Information

  • Lexus Model
    RX300
  • Lexus Year
    2003
  1. Hi guys I own a 2003 RX300 which never had given me any trouble so far. I had another driver telling me one day that I have no brake lights what so over. I thought it is just bulbs so I replaced the third light bulb and still no brake light. I did some search and discovered about the brake light module which located within the panel at trunk on the driver side as per this video: https://www.youtube.com/watch?v=2wdEh4SugCw It says that I could try a jumper solution at 2:48 which I did. This is when things get interesting. After I tried this, the brake light did come on when I stepped on the brake but I lost other lights (turn indicators, reverse and rear lights). At the same time I also lost power windows and the heat. I tried soldering every component on the brake light module, thinking it might be bad connections but still I have the same problem (no heat, no power window, no rear lights except brake). The power windows make no sound what so ever, so my guess is there is no power flows through the system at all. Nothing also happened at the display when I pressed the climate control button. The display works as the radio and CD is on. My guess is this was caused by me jumping the connectors at the brake light module? I checked the fuses with multimeter on the left side of the steering wheel inside the car and they all show continuity. Not sure if they are other way to check the fuses or maybe there are other fuses I should check? I can't be driving this car at the moment without heat (it is -20 here) as well no lights are working at the moment. I appreciate very much any help I can get with this! Thanks!