Ugo

Regular Member
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Ugo

  • Rank
    New Club Member

Contact Methods

  • First Name
    felix

Profile Information

  • Lexus Model
    rx300
  • Lexus Year
    2000
  1. hi everyone. i am kinda of a newbie here and this is my first post. my 2000 RX300 developed a problem recently. it starts fine, but then it dies immediately. unless i kept giving it gas for up to 20-30 seconds. this does not happen if i restart it immediately after driving with a warm engine. every other thing fine once it is running, though it stalls and tries to die if it alone long at a traffic stop. i have followed the steps of cleaning out the idle air control valve (IACV) and it moves freely, and the throttle body, yet the problem persists. the fuel pumps ohms out well and the pressure is good. my small research led me to suspect the fuel pump resistor, which is said to control fuel pump at low load (apparently the pump relay shunts a reduced voltages to the FP through this resistor at low loads, like immediately after starting). problem is i cant seem to find this part. where is the fuel pump resistor located in rx300?. a pic will be a mighty help. Thanks.
  2. hi everyone. i am kinda of a newbie here and this is my first post. my 2000 RX300 developed a problem recently. it starts fine, but then it dies immediately. unless i kept giving it gas for up to 20-30 seconds. this does not happen if i restart it immediately after driving with a warm engine. every other thing fine once it is running, though it stalls and tries to die if it alone long at a traffic stop. i have followed the steps of cleaning out the idle air control valve (IACV) and it moves freely, and the throttle body, yet the problem persists. the fuel pumps ohms out well and the pressure is good. my small research led me to suspect the fuel pump resistor, which is said to control fuel pump at low load (apparently the pump relay shunts a reduced voltages to the FP through this resistor at low loads, like immediately after starting). problem is i cant seem to find this part. where is the fuel pump resistor located in rx300?. a pic will be a mighty help. Thanks.