Do Not Sell My Personal Information Jump to content

M.Yasir

Moderator
  • Content Count

    177
  • Joined

  • Last visited

  • Days Won

    8

Everything posted by M.Yasir

  1. Good info here Same thing happened with my elder brothers 07 LS460L; solution was that the mechanic took out the latching machine out and aligned it and put it back again; then the trunk started to lock normally as it would do It is highly unlikely that the latch system will die; most likely it can be fixed
  2. Good question Welcome back; i am sure the 2014 must be more smoother with a refreshed dashboard
  3. Come'on guys, the car is already 10 years old, dont you think it can deteriorate, moreover it greatly depends on the environment in which the car is kept
  4. Absolutely agree man, the big solid yellow exclamation and then while in motion blinking explanation is even more frustrating but as i said not worth it so i will just close my one eye Here in this country you can pass an inspection even with the check engine light on, the inspection is not taking account the electronic part/ lights glowing in the dash, only mechanical inspection from underneath the car; oil leak check; Tyre tread check; break check; indicators check; headlight check; wipers check and you are good to go
  5. Hi Craig Thanks for asking, to be honest i let it go; it appears i just have to replace all the sensors inside the rubber which in my opinion not worth the money considering when i am already moving to Canada sometime this year;
  6. Hi Craig Thanks for the reply, After reading the above thread and multiple nested threads inside that, i came to realize that i should leave it as it is, i can wait for the initial 30 seconds to let the "AC switch off" display message in my Nav screen and then turn the AC on However on the side note, can you please help me in setting the TPMS thing, there is a warning light popping up always I am aware that the TPMS sensors are inside the rubber tyres but how to configure it thats a big question, i am aware that there is a reset button but unfortunately that is not working
  7. In my local market, i am going with the total quartz full synthetic 5W30 2 gallons straight away, experience is much better than the shell (also 5w30) oil which i used earlier, how better? is because i feel that now the engine is running a much smoother if you carefully feel it One note i would like to make that these days i am seeing the marketing is changed for the oil packaging cheaper oils are also hitting the market which are saying synthetic technology or synthetic blend (maybe not in the US), quite frankly have no idea whats the catch but i just avoid it anyways and pay little extr
  8. Hi everyone, Its been a long time since i posted anything here, so i purchased a 07 LS460 white (inside beige) at 183,000 km- full options minus two things which are the radar cruise control and the air suspension not to mention the LKA ( i am located in middle east), i had no idea of the previous owner no service history at all, yes i would say i took the risk but what i felt that the car is good since it had no dashboard lights, currently only caution light is there because of the front sonar system and the as usual the ridiculous TPMS After driving it for a while, what i imagine t
  9. Hi Craig The thing is unfortunately in this part of the world (middle east) no body cares and customer feedback have 0 value, and yes there is no lexus corporate here Can i buy an ECU from a junkyard for a lets say 2000 LS? will it work with mine?
  10. Hi Craig Yes i saw your post sometime back, but do you think that if i reach out to Lexus at this point of time they will entertain? considering that the car was imported to UAE, i will try to reach them and will report back, From your post what i can understand you did managed to change it in the year 2014, so i am guessing i still have a chance Looking at the PDF of the SSC, my VIN number falls within that range which is specified as compared below campaign-ssc-wl2-1998-gs400-ls400-sc400-ecm-replacement.pdf
  11. Hi Ok reporting back after a short drive, well it appears that the problem is solved now, and yes check engine light is also gone by itself after driving at slow and constant speed, so from the pictures below, exactly 1 box of fuel is remaining and it is showing 100 miles range which is normal, we can say this a success story!
  12. Hi All Well reporting back, following things got replaced Valve cover gasket Knock sensors (unfortunately the wiring harness was not used by the mechanic i think he was not able to connect it, well i will keep it for future) Fuel filter PCV valve with the gasket Two transmission coolant hoses which are below the radiator Some pics And the flashy new one installed Now the knock sensors and ECT sensor PCV valve old Replaced the two transmission hoses which are below the radiator which were cracked
  13. Hi Jim I believe we are not driving LS and expecting it to be loaded with the tech of this 21st century, its not fair to compare, i have driven the following Ford Mustang GT 2006- 4.6 litre V8 (brother in law owns it) Nissan Patrol 1999- 4.8 litre I6 (elder brother owns it) Nissan Armada 2006- 5.6 litre V8 (brother in law owns it) Lexus RX 330 (sister in law owns it) Lexus LS 430 2001 (elder brother owns it) Lexus LS 400 1998 (i own it) BMW X5 2015 4.4 litre V8 (my wife's sister husband owns it) Audi Q3 2014 3.2 litre V6 (my wife's sister
  14. There could be number of issues, ignition coils would be my 1st guess another guess would be after spark plugs I have also experienced hesitation in my 98 LS and it was due to multiple cylinder misfires, so i changed all the 8 spark plugs which solved the problem however i did not changed the ignition coils though I believe in 92 LS there is no ignition coil which is direct on the spark plugs (coil on plug), there is a rotor and distributor cap with wiring harness running around all over 8 spark plugs so your issue can also lie somewhere in the wires again just a guess
  15. well from my own personal experience i used a body deodorant to clean the MAF sensor in my 1998 sensor which worked really well
  16. wow thats a lot, in that money you could have replaced your timing belt ..... anyway glad you found the solution and fixed it, just curious why you didnt tried any junk yard to find the spare parts? i am sure in your country there will be junk yards full of lexus just like here since LS are being massively imported in this part of the world from Japan (right hand drives) and are ripped apart and almost all parts being sold individually making a good profit for the guys doing the business.
  17. This is a great topic and good work in progress, i just admire that how people dig in and start doing things in the engine bay themselves unlike here, i notice that in the pics the engine is so clean free of dust unlike mine which was a mess! and requires quite an effort to clean everything up, because of the climatic conditions i guess or may be the original owner after import he never bothered to clean up
  18. but how is that possible that by changing the rim size it will affect the behavior of the speedometer in the dash? i think you should go to an electrician or find a new console from the junkyard to rule out any possibility, OBD scanners which are capable of programming the ECU are expensive and it will be not worth purchasing it in my opinion just for this problem, I have a similar case in my broher in law Ford Mustang GT (2006), but in that car it is the other way around speedometer reads more speed than actual as per GPS of about ~10 km/hr
  19. Sure will do that as well about the PCV valve Well i received the spare parts from ebay, looks good and i can indeed see denso on the sensors, costed me around 26.48 $ for 2 sensors and wiring I am planning to buy the following as well before i take my car to the mechanic PCV valve PCV valve seal Fuel Filter (i can bet that the current fuel filter is around the same age as of the car 20 years, so i will replace it as well) Coolant temperature sensor I will try to find the above parts locally here since these appear to be inexpensive
  20. Thanks craig, soon after the starter was replaced and the car was in running condition i test drove it and it lacked that "punch" which it usually used to show when you press the accelerator pedal all the way to the ground at once, i thought maybe i am being too conservative but after 4 days of driving it drank half the fuel tank and gave only 100 miles like i said before I just want to make sure that once again the manifold will be open so this time i dont want to miss anything else, in this country its difficult to find good garages majority of the ones are only for show with good light
  21. Update: I ordered the sensors from the below link https://www.ebay.com/itm/232461386365 Well lets see when it arrives, will there be any possibility of bad Fuel Injectors Engine coolant temperature sensor?
  22. Hi Antony Yes thats right power steering pump is on the passenger side just above the alternator and somewhat diagonally below the fluid reservoir From that photo as craig suggested it looks like the leak is coming from the boot, that rubber part which looks like a coil, wear a pair of gloves before you inspect
×
×
  • Create New...

Forums


News


Membership