VICK187

Regular Member
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About VICK187

  • Rank
    New Club Member

Profile Information

  • Gender
    Male
  • Lexus Model
    GS300
  1. Well Hello Lexus Club

  2. does anyone ever get on here?

  3. I got my ball joints from advance auto parts

  4. So... I got my car back with a new fuel pump and I did my timing belt and spark plugs now my car running like a champ!
  5. the 2JZ after 90,000 mile maintenance
  6. VICK187

    My GS300

    My engine after the 90,000 mile maintenance!
  7. Same thing happened here but my mechanic says is the fuel pump

  8. My GS300 wont start either.... maybe I should check the anti-theft? It will crank just wont stay on maybe its not the anti theft...uhhmm <_<
  9. Ok... so know ived towed my car to the mechanic and he is telling me its the fuel pump. uuuuhhhmmmm... :chairshot: Now im wondering how much is this going to cost me????
  10. Does anyone know any good Houston Mechanics?

    1. VICK187

      VICK187

      I found one called CLEAR CHOICE LEXUS They replaced my fuel pump!

  11. Ok... So I just purchased a 2001 GS300 with 120,000 miles back in October 2010 the car was very clean interior and exterior. Car has been great all except for a small leak around timing belt cover. I suspect the cam seals have failed. After driving it for about 8,000 miles (making sure I keep oil in it)Its been running great, till this morning when I tried to start it. At first it seemed to want to start, going from a rough idle at first, to a smooth idle for a few seconds then back to rough idle then turning off. So I decided to leave it parked until I got back from work. First I tried listening for the fuel pump running suspecting that the fuel pump had failed but did no hear anything. I was was wondering whats the best way to check it? Also were is the fuel filter located on this thing? I have been researching common issues with these cars and now im scared it might be something more serious. BTW I checked my oil and found the oil level a little low so I added some oil but still no luck. Now that I crank the car it wont start at all. Does anyone know anything else I should be looking for?
  12. What's on your mind?Ok... So I just purchased a 2001 GS300 with 120,000 miles back in October 2010 the car was very clean interior and exterior. Car has been great all except for a small leak around timing belt cover. I suspect the cam seals have failed. After driving it for about 8,000 miles (making sure I keep oil in it)Its been running great, till this morning when I tried to start it. At first it seemed to want to start, going from a rough idle at first, to a smooth idle for a few sec...

  13. Hello Lexus Owners Club!