larrymcj

Regular Member
  • Content Count

    11
  • Joined

  • Last visited

  • Days Won

    1

larrymcj last won the day on June 1 2013

larrymcj had the most liked content!

Community Reputation

1 Neutral

About larrymcj

  • Rank
    New Club Member

Profile Information

  • Gender
    Male
  • Lexus Model
    RX 350
  • Lexus Year
    2013
  • Location
    Tennessee (TN)
  1. Anyone had Xpel protective film put on their Lexus? If so, are you happy? I had the dealership install it on my new RX 350 but I'm starting to have second thoughts and may peel it off. Just too many precautions...have to clean it with a particularly fine microfiber mitt/towel...can't put bug release on it...can't use a bug sponge on it, so bugs are a huge problem...film mfg doesn't endorse it going through car washes (my Lexus dealer puts all their cars through one each time it's in the shop). Basically, I'm just afraid of it and wondering if taking a chance without it might be better. I know the film industry and appliers think this product is way better than the older VentureShield by 3M, but still... Appreciate anyone else's thoughts, especially about using a good car wash with felt brushes and wipes.
  2. I just bought a new 2013 Lexus RX 350 and part of the XM trial subscription is XM Stocks. Unfortunately, I've had no success in adding the symbols for the Dow Jones Industrial Average (normally .DJI) or the Nasdaq (normally .IXIC) though normal ticker stocks add just fine. Has anyone figured out how to do this? Not having the Dow and Nasdaq at a glance makes it sort of useless. Thanks.
  3. Please disregard this post...I found the problem. Both my iPhone and my wife's are configured in the Lexus and somehow hers was selected so it obviously wasn't finding the Enform App.
  4. I bought a new 2013 RX 350 two days ago and I'm having trouble with the Enform Apps not working. I'm very technically savvy, using an iPhone 4S, and have already tried Lexus Support (the tech person there unfortunately didn't have a clue what was wrong). I have the Enform App on my iPhone, as well as Pandora and iHeartRadio, and Bluetooth is on all the time. When I first tried using Enform Apps, everything worked except Pandora. When I tried to use Pandora from the car I got a tutorial of "The application is not configured. Please add a Pandora account." I pressed OK and it went back to the main Apps screen and nothing happened. At that point, if I went to Pandora on my iPhone and selected a station, it would start playing on the car. But I shouldn't have to do that…and shouldn't get that tutorial when first pressing the Pandora button in Apps. I called Lexus Support and the only thing he could offer was to shut down the Enform App and Pandora App on the iPhone, then turn off the phone, restart it, then restart Enform and Pandora. I did this, and now the situation is even worse. Now, when I am in the car with the iPhone, Bluetooth connected, Enform App running and press the Apps button on the car I get the following tutorial..."To use the services, an active application needs to be running on the phone. For further assistance please contact Lexus Customer Assistance….". Well, the Enform App is definitely running on my phone and the phone is paired with the car, Bluetooth is on and I'm at a loss as to what else to try. I traded in an inferior car (Ford) but I think the Ford SYNC system was light years ahead of the Lexus Enform and Navigation system. Thanks in advance for any help someone might have.
  5. No...when it works, it works also when moving, by just pressing the voice recognition button on the steering wheel and saying "Phone" and then "Dial John Doe mobile". And also when it's not working it can be stopped. The system should work when moving or stopped...already verified this with Lexus. I'm going to try deleting the phone completely and adding it again...perhaps that will help. If not, I'll try adding the phone to one of the other three positions (you can have up to four phones) and see if that works.
  6. When I purchased my 2011 RX350 a couple of weeks ago the sales manager told me my Android HTC Incredible phone would integrate perfectly. He was correct...for the first week. Then I started having problems where the phone would be paired, but the Enform system couldn't see my contacts. I could dial by number with the car or use the phone to dial and it worked, but dialing by contact name stopped working. If I stop the engine and restart it, often the Enform system would then see my contacts again and I could use voice recognition to dial, but when it's not working, which is most of the time, trying to dial by contact name simply won't work. Also, when it's not working the contacts show up, but are grayed out and when it is working, the contacts display fine. I tried using several other phones but get the same problem...it's the car...not the phone. Any clues? No one at my Lexus dealership has a clue about the phone integration, which is very disappointing after just spending $50k on a new car.
  7. Larrymcj If I remember correctly, my dealer charges around $900-1,200. for a full application. May I ask what your dealer charges? Paul Holy crap...that's robbery! On any Lexus model here in Knoxville, the VentureShield is $698. That includes a run through the Auto Butler, then prepping all areas, applying the film, then another run through the Auto Butler. The areas covered are the entire front of the car, the front third of the hood, and the back of the mirrors. The job they do here is absolutely incredible...it's really hard to see unless you know it's on the vehicle. I've done more checking on this and 3M swears you can leave this on as long as you want on any color car and you won't see any difference when taking it off. UV rays definitely penetrate it so the entire car is equally exposed. Also, I haven't noticed that slight buildup on the door edge guards...I must have been behind some heavily smoking trucks here on I40 :-) Jumping rip off Batman! That's a substanial differance in price. If I decide do it I will look around and get some bids. When you get yours applied let us know how it went and about how long it took. I'm scheduled for next Monday...will let you know. The Lexus prep & design center here told me the actual time for doing the AutoButler prep, then warming up the body, making sure every microscopic particle of dust was off the care (clean room just like for painting), then applying the film takes about 5-7 hours. They have one dedicated employee who was trained by 3M and she is the only person allowed to apply the VentureShield. I think the film concept gets a bad rap because of the other wannabe films out there that do cause paint issues if left on for years. 3M warranties no problems at all and the dealership gave me a written document saying they would fix any problems.
  8. Larrymcj If I remember correctly, my dealer charges around $900-1,200. for a full application. May I ask what your dealer charges? Paul Holy crap...that's robbery! On any Lexus model here in Knoxville, the VentureShield is $698. That includes a run through the Auto Butler, then prepping all areas, applying the film, then another run through the Auto Butler. The areas covered are the entire front of the car, the front third of the hood, and the back of the mirrors. The job they do here is absolutely incredible...it's really hard to see unless you know it's on the vehicle. I've done more checking on this and 3M swears you can leave this on as long as you want on any color car and you won't see any difference when taking it off. UV rays definitely penetrate it so the entire car is equally exposed. Also, I haven't noticed that slight buildup on the door edge guards...I must have been behind some heavily smoking trucks here on I40 :-)
  9. I sort of feel the same way, but my research with 3M on the product shows that UV rays penetrate it so the paint underneath will be equally affected by UV rays. Also, dealership backs this product up with a lifetime warranty which clearly states they will replace the product or paint/repair/replace any part of the car that is ever adversely affected by it.
  10. I noticed the same thing on my new RX 350. When I turn off the car the headlights stay on and that's where the motor noise is coming from. I suspect the motor used to swivel the headlights right/left in curves runs all the time. When the headlights turn off...the noise disappears (at least for me).
  11. I just purchased a new RX 350 and while I like the idea of the VentureShield film protection, I'm already noticing a problem with it on the door edges the dealership protected for free. With normal highway exhaust, emissions, etc. the front edges of the applied protective film easily (read every couple of days) become black with a buildup that I have to wipe off. On my white car, this is annoying. I'm thinking this is more pronounced here because the leading edges of the film are forward-facing so are more susceptible. I want to add VentureShield to the hood, mirror backs, and rest of the front but am hesitant. I would appreciate comments from anyone else on this, particularly if you have a white or light-color car. Thanks.