SC400_Dude

Regular Member
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About SC400_Dude

  • Rank
    New Club Member

Profile Information

  • Gender
    Male
  • Lexus Model
    SC400
  1. HEY THANKS FOR THE WORKSHOP MANUAL BUT IS THERE ANOTHER ONE? THIS ONE IS MISSING A LOT OF PAGES. I WENT TO LOOK FOR AT-78, FOR EXAMPLE AND IT ISN'T THERE. THERE ARE SOME OTHER PAGES I LOOKED FOR AND THEY AREN'T IN THAT MANUAL. THANKS AGAIN.
  2. THANKS! I'LL TRY THOSE FIXES AND SEE WHAT HAPPENS.
  3. I have two issues: I bought my 92 SC400 a year ago. It has the small issues... the speedo doesn't work and some lights in the instrument cluster don't work. OK so I replaced one of the speedo sensors on the tranny and tested the other one and the speedo still doesn't work. I took out the instrument cluster and replaced the bad bulbs and tested the speedo electronics with an ohmmeter and all seem to be ok, ie, no opens or shorts. The fuses are good, of course... So its gotta be the wiring... which is gonna take some time... can anyone offer further advice before I kill myself checking all the wires? The second issue is the tilt-wheel steering. The tilt work going up and in-out but not going down. So I took off the steering wheel and expose the tilt gearing. I took the springs off and dropped the tilt assembly away from the steering column and ran it with the tilt switches. It works great in every direction. I lubed the gear shaft and the cams where they move the steering column, then reinstalled it and tested it before reinstalling the steering wheel and other stuff. Well, it goes up and down but not before banging into the end. I looked at the sensors and as far as I can tell they are still good. Any ideas on what else it could be? THANKS A MILLION FOR ANYTHING YOU CAN CONTRIBUTE... good
  4. I suspect the switch level indicator in the tank got stuck. Drive it around until you do a couple hundred miles, then check if it works by filling the tank half way. It might dislodge the gauge.
  5. I'm thinking of replacing my 92 SC400 radio system and speakers. The CD changer works great, incredible after 18 years, but its a matter of time... Any recommendations? I have no idea whether mine is a Pioneer or Nakamichi. But a modern system would be nice. It's a big hole to fill! Thanks in advance! BTW, I live in USA so please, no recommendations from UK or elsewhere.
  6. Hey, I wish I could post anything useful but all I have are problems I'm trying to resolve... Here's a weird one: The radio works for a few minutes then it starts to fade until the sound goes out. However, the CD player works just fine and has no problems. So at least I know the CD power amp is good. I'm wondering if the radio has a separate amp? Anybody ever hear of this problem? Any help would be appreciated. B)
  7. I was dismayed to find a lot of bad and broken links that were posted waaaay back in the beginning of this forum, because there is info that I'm seeking about repairs, parts and the like. Perhaps our kind moderators could put together some really good links that work for all of us SC owners? I'm new at this (just bought my 92 SC400) and would really appreciate the help. Thanks!
  8. Got myself a nice green 1992 SC400 for $2500. It has 136k miles and everything works except the following problems: the radio fades out after a few minutes of playing (the 12-CD changer works great, though!), the tilt steering wheel device only goes forward and backward, makes noise if I try to lower it, and the speedometer is not working. It drives like a dream and still has plenty of power. It is an automatic. I have heard that the tilt wheel steering device is a common problem that is easily fixed. Having some mechanical and electronic ability, I will try and do it myself. I could use some manuals, though. But they are expensive! Anybody have any advice on getting these manuals on the cheap? I searched eBay already. Anybody have similar problems as mine with the radio and speedo? I am wondering if the speedo cable is broken or if it is an electronic issue? What about the radio? It doesn't look easily replaceable in that style. Please contribute and help a fellow Lexus lover! Thanks! :D