All Activity

This stream auto-updates     

  1. Yesterday
  2. Is there any other reason than polution to replace this VSV when it's filter broke off?
  3. Hello, I have a 2002 RX300 with 125813 miles. I'm poor so until the Virus hit I couldn't afford Premium Gas; I bought Regular. As a result of using Regular Gasoline I would hear a rattling sound from my engine, when accelerating and or when I tried to increase my speed while going up inclines. Of course my MPG went downhill. I read alot on my situation and discovered that if I disconnect both Battery Terminals for 24 hours (it's what I did - others did it differently) I could reattach my cables, tune in my radio stations and then drive a minimum of 50 miles (I drove more), preferably on a Sunday. You should notice a huge difference in acceleration and everything else afterwards, including gas mileage. Evidently our Lexus vehicles (I suppose other makes as well) only perform as good as we drive; if we drive like a Sunday Driver then it'll be slow versus a very quick highway driver . Try it out. Good luck!
  4. I used to be a regular lurker here and on many occasion, used the vast cumulative knowledge base of these forums to work my 1997 LS 400 (owned since new). Last year I gave it to charity. Today I came across the Toyota LEXUS Wiring Diagram book I purchased for the sole purpose of discerning the wiring harness for my failed Nakamichi system. If you want it, message me. All I ask is that you pay $8.40 flat rate postage. Publication number: EWD283U
  5. Hi- Yes, I just came back to the forum. what's your question?
  6. Hi all! For us original LOC members-- I'm Back!! I recently bought another RX300 (for nostalgia, of course). The same as I had 15yrs ago, this time a 2002 RX300 AWD in the same indigo ink pearl. It has 78k miles and purrs like a kitten. I have a question about achieving max acceleration in particular situations. Since owning the RX300 15yrs ago, I've grown used to the quick acceleration of the '08 RX400h, '11 GS450h, '12 Bentley Flying Spur, and am finding it annoying trying to merge into traffic with the RX300. If i wanted to get the best 0-60 time in the '02 RX300, should i switch O/D to OFF? Should i start in Drive or should i shift it to LOW? And I understand the 99-00 RX300 had a PWR switch near the shifter, but it was replaced with only a SNOW button for the 01-03 years. Tell me your thoughts! -cduluk
  7. dewana421, many thanks for your advice. You gave me little push in a right direction and I actually followed it and got some answers. Based on readings battery seems to be in a good shape. Was completely depleted on Monday but with little boost car started at first attempt. Alternator readouts are somewhat ambiguous. I was getting around 13.2 V or 14 V which is little confusing. I made an appointment with Toyota to let them take look at it. I forgot to check for parasitic draw but if I can find little spare time I'm going test it today.
  8. Last week
  9. Recently purchased a 2004 SC430 - black with saddle - 157k. Have wanted one since 2002 when I saw one in the showroom. Long story short, I located one in Texas and after speaking with the owner, decided it was a worth making a deal. While waiting for the car to arrive in Colorado, I signed up for Lexus Owners Club and read as much as I could about the strengths and weaknesses of the car. All I can say is LOC is a fantastic resource for any Lexus owner, but I found it particularly valuable for my newly acquired SC. So far, I have replaced front and rear shocks/struts, both upstream O2 sensors, front brakes and rotors. Within the next month I will replace water pump, tensioners and timing belt. (previous owner did it around 95k) All repairs have been done based on recommendations and information obtained from LOC forums. The suggestions for aftermarket parts were invaluable - as were the recommendations for OEM parts. Repairs were accomplished by a local independent Toyota mechanic I have known for awhile. Cosmetically - the car is in very nice condition. It was garaged most of the time and it shows. Bottom line is a HUGE thank you to all the other SC owners for sharing your knowledge and resources on this forum. Thanks to you, I am enjoying the hell out of this car and plan to have it for many years to come. Here's a photo:
  10. First thing you need to check is voltage on battery. I bet you it’s completely dead. I would try jump starting it however if it’s completely dead it may not work. It’s highly possible that the new alternator failed and you were running the car on battery juice which eventually gave up. mid you are able to jump it I would connect the battery to another car and leave it alone for 5-10mins to get some charge and then try starting it. Make sure all headlights are turned manually off and not on auto. if starts then check the battery voltage while car is running. It should be between 14-15 volts DC. If yes than your alternator is good. If it’s around 12 or lower then alternator isn’t working. mid battery isn’t that old you should take it out and get a replacement from where you bought it. It should be a free swap.
  11. Few days ago a new alternator was installed at the local Toyota dealer. Car was driven for couple of short trips afterwards and performed perfectly. Now after being parked for 3 days it is completely dead. No remote, no dash light, no signal of anything. I used mechanical key to open the door and than tried starting up with the key fob. Nothing. Key batter is only few months old. Car battery was in excellent shape just a few days ago. Where do I start...? New battery..? Could it be related to the new alternator install, wires, fuses...? Or maybe engine immobilizer system...? Unlikely though since there are zero dashboard indicators on. Car is completely dead. Any advice most appreciated
  12. The towing prep package for the 2020 RX450h included the following at a retail price of $270: HEAVY DUTY RADIATOR AND COOLING FAN ENGINE AND TRANSMISSION OIL COOLERS It would cost thousands of dollars to retrofit these components if you could find someone willing to do it which is doubtful. The biggest problem is probably the engine oil cooler since the engine you have probably can't accept one without replacing major components. On one particular Toyota model with a V6 engine, the estimated cost of adding just the engine oil cooler to a vehicle that didn't come with the tow prep package was over $2,500. Normally a Lexus dealer would have to prove that towing a camper caused the failure of a warranted vehicle component but this is a case where the car maker offers a towing prep package and specifically states that vehicles that don't have the package are not designed for trailer towing. My suggestion is to use a vehicle rated for towing. Or buy a nice tent and don't keep any food in it if you're camping in bear country! My wife and I used to do a lot of camping when we were (much) younger - a lot of wilderness backpacking and some campground tent camping from a car. My wife's idea of camping these days is staying in a Holiday Inn Express.
  13. they may be the same sensor, but they have different wiring and different part numbers. look them up at rock auto parts. IF you replaced one sensor last year, replace the other now.
  14. We have a 2020 RX450HL which unfortunately doesn't having the towing prep package. According to the owners manual they do not recommend any type of towing without the towing prep package. We are thinking about getting a small teardrop trailer, but it seems inadvisable without the tow package. Is there a way to get the towing prep package after purchase via Lexus? Or is there an aftermarket option available? Thanks, Kevin
  15. Ok, sometime between 9pm and 1am this evening my 09 rx350 lost all quarts of oil in it (it was full as of 245pm today). I believe this is due to the recall that was put on this vehicle several years back. Has anyone had any luck with getting anyone to do anything at lexus/Toyota about this? I am a single mother on furlough from my employer due to covid 19 at the moment and cannot afford your fix anything on my vehicle. More less a major issue like this. Thank you in advance for any helpful information you can give to me.
  16. I do not know. I will check it tomorrow ASAP. Thanks! I took the wiper fuse out from the box inside the car because the wipers kept running, then stop then keep running.
  17. Hi, I just got a 2005 GX470 with 212000 miles in great shape with air suspension, nav & Mark Levninson audio for $6500 out the door, I would say (if still available) that it's a little high but if plan on keeping it it is sooo worth it!!
  18. Fuse #2 (20 amp) in the engine compartment fuse box is for the wipers. Is it blown?
  19. I’m very excited about this purchase. Looking forward to learn all I can about this vehicle. I traded in my 2013 Nissan Frontier for this GX a few days ago. Already have plans to lift it and throw some 33s on it.
  20. don't need front plate in most states ,,,in ohio starts july first ,,,,got my car in march dealer tried talking me out of putting bracket on the front ,,but i had them do it,,, they drill two holes ,,,can always cover them come july first
  21. Wipers not working on a 99 LS400. Replaced column stalk and wiper motor. Didn't help. Any ideas would be appreciated. Rick p.
  22. I recommend you to buy Lexus 2016. I also owned this car. The maintenance of this model is affordable and cheaper than other models. I normally purchase all its accessories and parts from Ritecoupons and currently, they are offering money saving coupons that help you to save more.
  23. I have a 2000 ES350 with check engine codes P1130 and P1135. I just looked up the part from Napa and it shows part number, Denso DEN 2349021. It looks like this same sensor is used in two different areas, Upstream Rear;Bank 1 Sensor 1; Upstream Front;Bank 2 Sensor 1. I replaced this same part last year for the Upstream Front; Bank 2, Sensor 1 and was hoping somebody can confirm that this same part is used in both locations. Thank you very much!
  24. I suspect as long as you have the rest of the required equipment to run GPS navigation it should work just fine. The dead giveaway is usually on top of the vehicle. If you see the shark fin on the roof of the car then it has everything you need for navigation. You should, in theory just need the software installed. However, I have a similar question. My Lexus RX450H also has the smaller screen, without navigation. Does anyone know if there is a way to get the navigation software installed on mine without paying the dealership an absurd amount of money for some basic maps????
  25. Hi, This is my first post. I'm interested in buying my first Lexus. I'm looking for an ES 3 series. Are there any problems with any of the engines as to burning oil or blowing head gaskets due to poor design, as some Camrys and Corollas have? Thanks
  26. Earlier
  27. All, just wanted to chip in since there are so many helpful comments here. A wrong Lexus key was inserted into my IS300, resulting in my key not being able to turn at all. I use the spray lube, dry variety, and still no luck. My mechanic buddy suggested I use a straightened out paper clip to move things around in the key hole, and voila! It was such a simple thing to try, and I worked, so I wanted to share that with you all.
  1. Load more activity



  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up