Do Not Sell My Personal Information Jump to content

Ls400 low oil pressure


jettyjet400
 Share

Recommended Posts

So yesterday my car literally shut off on its own and it read low oil pressure on the dash, I tried to start the car, but makes a really bad grinding sound around one of the pullies, I have oil in motor.  It every time I try starting it makes a really bad and unsettling sound not sure what it could be any ideas? Could the motor have sized on me?? What can I do to fix or check the problem without trying to start car

Link to comment
Share on other sites

I believe your car has a timing belt. Perhaps it has failed and needs to be replaced. In any case, it is best to not try to start the engine until it is checked. There are most likely youtube videos that show you haw to check the timing belt.

  • Like 1
Link to comment
Share on other sites

image.png

The above diagram shows the timing marks for crank and cams.
You would also need to check the tension and condition of all components to see if serviceable if not then replace all parts

Check also the air con pump and other ancillary components to ensure they are turning free.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership