Do Not Sell My Personal Information Jump to content

92 Ls400 Won’t exceed 1800rpm


Recommended Posts

Hi guys! My names Jacob and I just bought a 92 Ls400, Absolutely thrilled with my purchase and I know it’s a project but I definitely wanted to take it on. 

So it starts up and idles just fine, light accelerations are perfectly okay but as soon as you hit about 1900 rpms it drops down to about 1300rpms and jerks just a hair. I can feel that the power is there it’s just not wanting to exceed between 1800-1900 rpms. I don’t think it’s transmission related because I can get it to about 48mph  but it will not go over the 1900 rpm threshold. 
 

also speedo needle works once every a couple minutes and the reading is generally off. I’m assuming this is a wheel speed sensor issue? Can someone point me to the sensor that actually reads to the speedo ? Hoping my odometer comes back and works after the speedo works 

08C2128B-0973-4EE0-B5F1-A53EA9A289BC.jpeg

Link to post
Share on other sites

Having owned a similar 1990 LS400 from new until 2003, I would suspect that your performance issue is in the induction system and most likely in the throttle body.  The throttle body is easily damaged.  This is something best left to a professional technician.

Your speedometer problem is is most likely in the speedometer itself.   it is extremely common for the needle to stick, occasionally operate and be inaccurate.  These guys should be able to help you:  https://www.taninautoelectronix.com/

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...