Do Not Sell My Personal Information Jump to content

92 ls400 speed/tach/temp/fuel background light intermittent but needles stay brightly lite ?


Recommended Posts

92 ls400 speed/tach/temp/fuel background lighting has suddenly gone intermittent but gauge needles always stay brightly lite and move?  Makes it almost impossible to tell how fast you are going.  Then, for a few seconds, dash lights up like normal.  Seems like a loose connection somewhere to me but I have no clue where or what fuse might control this lighting.  I have rotated the dash dimmer control all the way in both directions and it made no difference.  Any help would be appreciated.  Thanks.

Link to post
Share on other sites

Thanks, but I am done sinking money into this car.  I tried to trade it in when I bought my Honda (my every day drive) and the dealer refused to take it (and that's when the AC and the odometer worked, which they doesn't anymore).  The 'we'll buy any car' sites will only give me $500 for it, so for now a flashlight strapped to the steering column will do for this winter. :-)   Probably junkyard when summer comes next year.  Sad, it is a very comfortable ride.

Link to post
Share on other sites

Well ... it can take a lot of cash to keep these cars going as they age.  I spent around $1,000 per year on repairs and maintenance in the last several years I owned the 1990 LS400 that I bought new and sold in 2003.  Maybe advertise it on Craigslist.  There are people out there who value these cars.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...