Do Not Sell My Personal Information Jump to content

Horn quit on 06 430sc


Recommended Posts

This appears to be a common problem.  It is often the cable in the steering wheel cover.  Anyone else have experience with a horn that does not work?  The relay appears to be good as it is the same circuit as the light switch.  The lights work fine.  Could be the horns themselves. 

Link to post
Share on other sites

It's doubtful that both horns would fail at the same time but it would be easy to find out with a simple 12V test light.  There are several potential causes.  The horn on the 2000 LS400 I used to have started barely working if at all when something inside the horn pad/air bag assembly broke.  An indie repair shop installed a salvaged horn pad / airbag assembly for around $800 which was great since the new part was over $2,000.

Or it could be a defective spiral cable in the steering wheel.  The indie shop that fixed the horn problem in my 2000 LS diagnosed the problem in only a few minutes but the mechanic was a former lexus dealer mechanic.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...