dgal

'97 ES300 Stalling- Help Please!

Recommended Posts

My '97 Lexus ES300 has 89,000 miles and is having a stalling problem.  It is currently at its third mechanic and he is also having problems figuring out what the problem is.  The first time it stalled was after driving on the highway.  The first mechanic cleaned the throttle body, but that didn't fix the problem, it stalled after driving around town (wasn't on the highway).  After doing a little research I noticed people saying it was a dirty Idle Air Control valve so I told the second mechanic about that.  He also said the car was sitting too long with old gas and I needed to get that cleaned out because it was dirty. After doing that it drove ok the first day but stalled after I got off the highway again. So I towed it to a third mechanic after breaking down and of course, it wouldn't stall for him at first (he wasn't able to get to it right away so sat in his lot for few days) so I told him to go on the highway with it and it stalled as he pulled into the shop.  He was able to pull an error code that said it was some sensor (forgot the name) and he bought a new one but that didn't solve the problem either it only ran worse so he put back the old one.  It is also having a little lurching on acceleration and after stalling it also didn't sound like it was running well.  He has so far: checked spark plugs, vacuum leaks, throttle posturing, airflow sensor, checked coils and checked the fuel pump.  After searching on these forums I came up with:  possibly damaged air intake tubing, check PCV valve, and getting an induction kit (don't know what that is). I plan on passing on these possible fixes to the mechanic.  Can anyone else suggest what the problem might be?  Thanks!

Share this post


Link to post
Share on other sites

It could be helpful if we knew what code it was throwing.  Basically your saying that the air/fuel ratio is being thrown out so badly the car stops running and THEN it wont start again causing you to have to tow the vehicle to a repair shop. That is not a sensor problem most likely. But the list of things it could be are too numerous to get into without the aid of a diagnostic scanner.  Sorry I cant be more helpful.

Paul

Share this post


Link to post
Share on other sites

It only gave the mechanic that one code at time of stall. I’m almost positive it was air flow sensor. I will call him back and ask. But it didn’t end up being the problem. The car didn’t give any other codes. Just the fact that you are trying and asking me questions, is already helping. Thank you.  The first time it stalled it let me start it up again to make it home.  This last time it got to a point it wouldn’t let me restart it and I had to wait a few minutes before it let me restart the engine. 

Share this post


Link to post
Share on other sites

It cost nothing to be helpful. 😉 New question,  do you smell gasoline from the engine or exhaust when this happens? The real problem with a too rich mixture is the possibility of damage to the Catalytic converter. And the airflow sensor is most likely references the Mass Airflow Sensor on the intake. Admittedly,  I own a 97 LS400 and an 02 SC430 so I am not up to speed on the specifics of your car. But I always recommend that we own a good Diagnostic scanner because for whatever reason,  sometimes the codes dont stick in the memory. A nice one for personal use is available for around $100.00. Sounds like a lot now. But will pay for itself quickly if you do your own maintenance or own an older car.

Paul

Share this post


Link to post
Share on other sites

Oh yea. Let us know if there has been any other weirdness that you can think of. Does it happen on really hot days only? Has your gas mileage  changed?These types of problems often come with other problems that seem completely unrelated sometimes. 

Paul

Share this post


Link to post
Share on other sites

I don't remember smelling gasoline, but I do fill it up with regular gas, not premium.  Are you suggesting it's the choice of gas that is messing with my car?  Why would I buy a diagnostic comp tool when the mechanic already has one?  I have no idea about the mileage, I'm really not car savvy at all.  It happened in winter and summer.  Thanks.

Share this post


Link to post
Share on other sites

No. Not talking about the type of gas, i.e. regular or premium. But if the car is running rich ( too much gasoline being injected into the cylinders for the amount of air supplied) it will smell like gasoline and definitely will not run right or even run at all. Too lean (too little fuel being injected) and you wont smell gas. And if you are not getting  a spark, it will smell like gas too. Im just trying to figure out which way the airflow mixture might be going to cause the problems your having. A proper ratio is called "stoich". Dont need to get into an engineering lesson here but if either is out of normal range,  the burning efficiency goes down. Loss of power, poor mileage or no affect on mileage etc. I asked about outside temperatures because it could be an electronic issue. One thats only caused when it gets too warm. Your ECU (electronic control unit) is the brain's that make all of the good things happen. But its just a computer with parts that fail like everything else. I had to change every capacitor inside my 97 LS400 ECU because they were old and out of tolerance. It didnt throw any codes either. But it was just kinda "off". Trying to diagnose a modern car is already difficult enough. With a diagnostic scanner,  you can check your car yourself in moments, then let your mechanic know. You could spend thousands trying to figure out what your particular problem is without one. Considering the age of the car, that makes no sense. 

Psul

Share this post


Link to post
Share on other sites

The sensor that gave the error message was the throttle position sensor and replacing that did not fix the problem 

Share this post


Link to post
Share on other sites

https://www.yourmechanic.com/article/symptoms-of-a-bad-or-failing-throttle-body

Or it could be this. Or it could be both. You stated you use regular instead of premium. Carbon fouling is is a possibility.

Thats about all I can contribute on this matter from a distance. Please let us know what the end result turns out to be. Maybe it will help someone else down the road.

Paul

Share this post


Link to post
Share on other sites

I was told it was ok to use regular gas instead of premium. You are saying it’s not?

 

it does sound like it would be the sensor, but like I said, replacing it didn’t help at all. But after reading this... “.Replacing the TPS will include clearing relevant fault codes, and may require software reprogramming of the new TPS module to match other engine management software” Maybe the tps module needs reprogramming and he is unaware of this. Shouldn’t it automatically happen with an oem part?

Share this post


Link to post
Share on other sites

From what I know about the ECU and fuel management,  the ECU has to compensate somehow by adjusting the engine timing. I am not 100% knowledgeable about the details though.

As far as type of fuel, as long as it is a quality gas with additives for cleaning the fuel system, it should be OK. Ifyou get any knocks or engine runs momentarily after you shut it off, thats definitely an indication that your Octane is too low and would need to go up to at least a mid-grade fuel.

Paul

Share this post


Link to post
Share on other sites

No, I never experienced that issue with the engine.

Share this post


Link to post
Share on other sites

The "Reprogramming" referenced in the article is a general piece of information that may or may not apply to your vehicle. My 97 LS400 has a specific procedure written by Lexus as to when and how this particular procedure should be accomplished.  It is usually indicated when you do an ECU reboot caused by disconnecting the battery and connecting the positive and negative battery cables together for a few minutes to completely drain any power from the computer ( ECU), clearing the memory of any run settings it has stored and resetting it back to a base setting. After reconnecting the battery,  you start and run the engine at specified RPM's and time so the computer can re-learn and adjust sensor inputs etc. for optimal efficiency. But I must reiterate that I do not know if such a procedure applies to your specific year, make and model.

I did just notice that you have a 97. Have you done any research on the requirement to have your ECU inspected for possible capacitor failure? There is extensive information about this in the LS400 section. Just a thought.

Paul

Share this post


Link to post
Share on other sites

Just by googling the ECU capacitor failure, I didn't see my '97 lexus es300 on it.

Share this post


Link to post
Share on other sites

Well, I took it to a AAA car center that had an expert Toyota mechanic and he said i was the Throttle Position sensor and Mass Airflow Meter.  And he said you also have to do something to teach it to relearn the system (that was probably why replacing the TPS alone didn't fix the problem with the previous auto shop it was in).  They also told me the power steering pump is leaking and I need new valve cover gaskets, the 2 axles are broken, the right one needs to be fixed right away, Rear struts need to be replaced (knew about this prior), brake master cylinder needs to be replaced (also knew about this prior).

My questions are:  1.  Is there an easy tutorial on how to get car to relearn the system somewhere so I can show to my previous mechanic?  The prices at this shop are double his!! 

2.  Is this worth it anymore?  The car is over twenty years old!  But I did just pay for new tires, fixed brake and axle and payed for false diagnosis mad for the current problem.

Share this post


Link to post
Share on other sites

I have been thinking about your question "Is it worth it anymore?". Transaxle, struts, brakes, valve cover gasket power steering pump, brake master cylinder. All of these parts combined are probably about  $3.5-4K. And if you can't do the work yourself then I would have to say "No" its not worth it. Even knowing it's cheap on insurance and you have no car payment. And even if you could buy the parts and install them all yourself saving yourself a ton of money in Labor cost, you would have to do a compression check on the engines cylinders to see how healthy the rings and valves are. And if anything happens to the tranny etc, you could just buy another used Lexus for less money with way fewer miles and probably in better condition.

I like older used cars. To a point. I own a 02 Acura RSX Type-S with 266K Miles, a 97 LS400 with 264K miles and an 02 SC430. I'm head over heels in love with the SC430 even though it had 100,641 miles when I bought it back in April. It has the 3UZ-FE engine which is the follow on to the famous 1UZ and 2UZ engines from Lexus. I fully expect to get 300K miles from this package easily. And the car is just drop dead gorgeous. I got a personal loan (I couldn't get an auto loan because it had over 100,000 miles) for $8,000 or $179.00 a month and I am going through each system as necessary when some extra money finds its way like from overtime or something.. I am right now, maybe foolishly, carrying only liability insurance. If it gets hit they will total it out due to it's age most likely anyway. Car Fax has an app that allows you to see the maintenance history on the vehicle as well as the resale value etc. But I could have just driven it for 100K miles just as it was. I think it's time. Let her go. Look for another one in better shape that you can swap the tires too. Good luck.

Paul

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...