Do Not Sell My Personal Information Jump to content

New member 91 celsior won’t turn over


Recommended Posts

New member here, I have a jdm 91 Toyota Celsior. Starter was making noise during start up so I thought it was going bad. One day car stop doing anything. I would put the key in and everything works but it won’t turn over. I figured it was the starter. I changed the starter put everything back together and still nothing. I tried a new starter relay still nothing. It has a brand new battery. All fuses are good including fuses user the dash. If I bypass the starter relay it will crank over but will not start. Uses the key does nothing. Came here to see if maybe someone can help me big thanks in advance.

Link to post
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Similar Content

    • By Logan pool
      I took my 98 ls400 to a mechanic because the car would not accelerate unless it was completely floored, I had already replaced the throttle position sensor and I took it to the mechanic to replace the acceleration position sensor, after he replaced it and reconnected the battery the car wouldn’t even start anymore and he was getting codes for something like a security problem, and the security light was flashing but if I remember right it has always been flashing. There was also a code for the ECM (computer), I have no idea what the problem is so anything anyone can tell me would help, thank you.
    • By DavidLS
      Anyone know what this is ? 
      next to the drive train. Not the bushings in the back it’s more forward 


    • By two.colored.ls400
      Does anyone have a part number or a link where I could find a new fuel pump for my 2000 Ls400???
    • By markquila
      Hello -
      My daughter totaled her 95 so we found a 96 and put the much lower mile engine in. Engine runs fabulous just like in the other car. After a few hours of running, the engine light comes on. Nether LS had codes before the swap Checked codes and get these: "PO450 Evaporative Emission System Pressure Sensor Sensor/ Switch" and "PO430 Catalyst System Efficiency Below Threshold Bank 2". . 
      What I could find on out there was limited but I believe the 96 had an emission system that the 95 did not. I still have the 95 as a parts car so looking for best options to turn the engine light off for these errors. Again, engine runs fine and she is driving it every day. 
      Thanks in advance for any assistance. 
      Mark 


    • By Rolfjy18
      I recently purchased a 1997 Lexus ls400 coach edition with 176k miles. As we were driving it home, the check engine light came on. We took it in to a shop that we've been going to for years and got a reading. They said it was the catylitic converters and that they needed to be replaced in order to pass inspection in Virginia. Since that shop only used brand new parts, each converter would cost around 2 grand. I started looking for cheaper alternatives and found some on rock auto and carparts.com for around $42-300 and was wondering if those would be a good idea to buy. Most of the ones I found had warranties so that would lessen the risk.
×
×
  • Create New...

Forums


News


Membership