Recommended Posts

My 92 Lexus has been a very reliable vehicle. Only major problems have been leak in a/c and power steering pump. Replaced one light bulb in dash over temperature gauge and now I see that the turn signal indicators in dash do not light  or blink when all the exterior lighting for turn signal is working properly. Any suggestions on source of problem. Also noted that gear shift position in dash for N to D are not lighting.

Share this post


Link to post
Share on other sites
1 hour ago, James E Thompson said:

There is a knob on the lower left side of dashboard which controls the light level in the dash. I might be turned off!

If that was the case they would all be off. Probably just more bad bulbs. Most people replace all of them,when one fails the rest will be next 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By JDent
      My car wont start.  I checked the battery and was only showing around 5 volts. I charged it overnight and it was still showing 5 volts. I took out the battery and had it tested, it was bad.  I put in a new battery and the car still won't start.  The battery light and service engine light are on and the dash lights won't go out when the battery is connected. With all that the car won't even turn over. I could use some help if you have any ideas!  Thanks.
      James
    • By Moe47
      Hi guys,
      My '00 LS400's odo baclight burned out recently. I have heard a lot of people having problems with climate control display and fixing it, but couln't find anything on the odo/mileage counter display. I can see it's working fine, just the backlight won't turn on. Could really use your help here!
    • By B J Chitty
      my dash lights dont seem to be working II cant see my needles or anything in there
    • By Pax96
      Hello!
      I am a new Lexus owner. I just bought my 1996 ES300 a few weeks ago. It is overall in good condition with 250K on it.
      It does need some work, though. I would really appreciate some of you fine and educated folks helping me get a grasp on my cars issues and seeing what work I can do myself.
      I know it needs a speed sensor replaced, which is causing it to run idle at about 1500 RPMS and it has trouble accelerating/ drives a bit rough. It shifts smooth when it realizes it needs too.
      Today I noticed something new. When I have the lights on(headlights) the internal dash light dims and when I accelerate it stalls. If I have it at a steady pace, it is fine. Once it stalls, she starts up again no problem.
      I am taking it to a mechanic for a more thorough check on thursday but I worry about driving it to work and back with it acting up.
      It also needs to have the gasket seal replaced around the engine block. Right in that seal where the engine cover connects to the rest of the engines body. It is a very small leak out of this area and doesnt affect the oil levels. Mechanic quoted me about 200-300 to fix.
      Could you please help me diagnose my issue? Thank you! Happy to be apart of this group.
    • By Bigsky64
      Hi all, new to forum. Just purchased a 2011 CPO ES 350 with all the trimmings. I wanted to see if anyone has swapped stock DRL with and LED bulb and if so, provide feedback and specs. Appreciate any replies.