BeachBumForever

Where is 2003 ES300 PCV valve located?

Recommended Posts

Need help locating PCV valve on my 2003 ES300. Photos will be helpful since I want to install a new PCV valve on the car. Any suggestions on parts and removal/install will be appreciated.

Share this post


Link to post
Share on other sites
 

BeachBumForever,

Here's a picture of the same engine in a V5 Camry of the same year. Up near the firewall, passenger side, under the intake manifold. Fussy to get at, but not impossible. Found picture on another site.

    

100_2148.jpg

 

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

This is located on passenger side of vehicle on rear valve cover.  Usually has large foam covering over the hose. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By CorrosiveSmoke
      I have a 2000 lexus es300 at 136000miles in park or neutral I can rev the car up just fine but when I put it into gear the rpm barely creeps along even with my food to the floor, it gets a little bit better after the car is warmed up but not by much It still takes a minute for it to wind up enough rpm to start accelerating, I know it needs a couple knock sensors. I'm running some Chevron Techron Fuel System Cleaner through it now. any advice could it be the evap canister or pcv?
    • By BeachBumForever
      What do you all suggest as the best pure synthetic oil for a 2003 ES 300 with 209,000 miles? Runs perfectly with a very small (weekly drip) using Mobil 1 (5W-20). Also, what filter is recommended. Located in NC Piedmont region. Car is only driven <5000 miles a year.
    • By BeauR
      Hey everybody!
      I just became the proud new owner of a rare 1992 Es300 5 speed. I've been looking for a long time and finally tracked one down. Its in pretty good shape, I got lucky and found one with only 1 previous owner and she had it what work was done on it performed at a local toyota dealership. But it isn't perfect by any means...
      It has 398.000 miles on it for starters. There aren't any leaks fortunately and the transmission still seems to have life in it but obviously it isn't going to last too much longer without my divine intervention (and hopefully LexusOwnersClub.com too). Not too many cosmetic issues. I bought it in the Sacramento area so the front seats leather is dry and have split a few seams on the drivers side and the leather on the door panel surrounding the door lever has dried and shrunk to the point of needing replacement. The rear Passenger window came out of place and both mirrors are loose at the pivot point that attaches to the car body. Also the power antenna and motor is broken and the passenger side speaker doesn't work. Otherwise its in very good shape. I plan on rebuilding or replacing as much as possible on it or at least whats reasonable and when I do that I would like to upgrade as much as possible. Basically I'm going for a build based on the Midship Runabout guide  ( http://midshiprunabout.org/mk2/why-the-3vz-fe-is-the-best-toyota-v6/ ) and the Toysrme 3vz-fe tuning guide ( http://www.mr2.com/forums/threads/1899-Toysrme-s-N-A-3vz-fe-Tuning-Guide-(Applies-to-all-N-A-v6-s) ).  I have a motor with 180,000 miles on it that I plan on doing a complete tear down and rebuild and I want to try to install an E153 transmission and use a LSD from a MR2.  I haven't been able to find any useful info on a good clutch setup yet but perhaps someone here has some insight. 
      So basically I'm on here to get whatever this forum has to offer. Tips, tricks, advice, warnings, parts for sale or sources for parts would be greatly appreciated!!! Also since there is alot of knowledge and experience buried in this site I figured that my project would be a good opportunity to consolidate all of the significant information into one solid thread. I will be posting pics of what I'm starting with and will document my progress on the way. I will also post links to anything that I find useful as I come across it. I've read up on alot but I haven't had the opportunity to pursue anything major yet. I'm not incapable but feel free to explain things to me like I'm incompetent I'm sure it will make things easier in the long run.
      My goal is to build a "brand new" and improved 1992 Lexus ES300 and I would a greatly appreciate any insight or guidance.
      Thanks to all
    • By BeetleJuiceDNL
      I just wanted to say before i continue, I'm 21, Female and this is my first car I've owned for about 3 years ( not that any of this is really important)I'm starting to want to learn more about cars and how to fix my own problems and save money instead of relying on a mechanic. So far I have repaired my busted front bumper, repaired and replaced R headlight housing and bulb, and Replaced an 02 censor.
      I'm having issues with my transmission shifting gears in cold weather, but it runs like a dream in the summer. This was a problem last winter but wasn't as bad. Before, while accelerating and merging over on high-way, it wouldn't use the 4th gear at first but then it would shift gears after driving for a bit. Does the same problem now, but won't change gears at all or takes 10 mins+ to shift itself. sometimes has issues shifting 2nd gear to 3rd.
       es300 is 206xxx miles, 1999 model, and the transmission was rebuilt July 2016. I'm afraid this might have something to do with the previous failing but i want to try and fix the issue myself but can't figure out why this is happening or where to start. Coolant meter is always where it should be, oil is changed religiously, 02 sensor bank 1 sensor 2 needs to be replaced.
       4000 rmp at 75mph... (o/d drive is not on). Sometimes when braking hard or getting off high way, doesn't accelerate as it should, almost as if it skips 2nd gear. Accelerating 1st to 2nd at stops goes back to normal if I restart engine. 
      Over all, why is this happening and how can I fix it? Only happens during cold temperatures below 40.
    • By itsdancarl
      I have a 1994 Ls400 with an odd suspension squeak. The squeak only happens when braking. Definitely not a brake squeak. The squeak sounds more like a chatter and gets louder depending on how fast I'm braking. But this squeak does not happen when in reverse. I've replaced the UCA on the driver's side because the ball joint boot was torn. Both front struts are brand new, and just today I took the sway bar bushings off and greased them. Sway bar endlinks don't have play, and the rest of the ball joints don't have play. Still the same noise. Any suggestions on what it could be?