fuzzy1

intermittent speedometer

Recommended Posts

I have a 96 LS400.   for years, the speedometer has intermittently not worked...  it may not work for a few minutes, or a few days.   I have learned if I wack the dash, it will start working.  any ideas to fix this without replacing the instrument cluster?

 

thanks in advance

 

tr

Share this post


Link to post
Share on other sites
 

There are no user serviceable parts on the speedo. The Lexus instrument cluster boggles my mind at how beautifully complex it is. An engineering work of art is the best way I can put it. As long as everything else is working (i.e. trip meter, odometer and cruise control, lighting) you can be certain that the speedo itself is at fault. The only way to repair it is to either replace the speedo assembly itself (which is not too terribly difficult "or" replace the gauge cluster. The same goes for any of the actual gauges. I am an electronics tech of 35 years. It's not difficult to pull the cluster, get the P/N off of it and find one on ebay to replace the gauges. Just swap the "top" board with all of the coils of wire and other components to move your original/true mileage (stored on one of the chips) over to the new cluster. Takes less than an hour to do the whole thing. You need a phillip's screwdriver and a thin blade flat is helpful. There are if I remember correctly, three ribbon cables at the top to switch over and three other normal type of connectors on the bottom. That's about it. I had the same issue. Did what I am recommending. worked fine. No more speedo issues. Easy squeazy. Just a little costly to buy a used cluster. Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now