• Similar Content

    • By Robshow
      I installed a Rutech bypass and block off plates and my initial check engine light went out.  A day later I get the P0418 error telling me relay A is bad or there is faulty wiring etc.  
      Does anyone know where the SAIS relay is located for P0418?  I have been searching to the point of insanity. :)
       
      thank you 
       
      2006 Gx470 4.7l
    • By 914lps
      Hi,
      My 1991 LS400 is having a cooling issue.put new radiator on two months ago. All was good after that.
      Now when car has engine on and I'm not moving like when parked or in traffic the engine temp slowly starts to climb up.
      ehen I give it gas and start to move, at fist there is another small jump in temp but in a short distance the temp goes down to where it should be. Until I'm at a stop. Then it start going up again.
      No loss of coolant. Mechanical engine fan is working.
      I'm thinking either water pump is acting up or it is the electric fans.
      I'm leaning to it being the fans. How can I see if they are on and how do I check them?
      Where is the fuse for the fans? Where is the temperature sensor switch?
      How do I go about figuring if it is the fans and why they are not coming on (if in fact I find they are not coming on)?
      As always I thank all of you!
       
    • By Kie
      Hi!
      Have any you guys had a problem with the Rack&Pinion?
      I went to the car service around my house(Knoxville, TN). They told me mine is leaking and needs to be changed. 
      I'm having a hard time deciding to change or not because it cost like 1500$
      Do any of you have recommendations or any other place I should have service?

      Thanks!
    • By xxiLexus
      So I recently went out of town and let my cousin drive my car for about 5 days, however when she returned the car to me I noticed the USBs under the arm rest aren't working anymore. I used to always play music via USB (and bluetooth sometimes) and charge at the same time. I've found an alternative to this which was utilizing the cigarette lighter port and buying a USB cigarette lighter device. Im thinking its fuses that went bad or got fried but if anyone knows a fix to the USBs not working that'll help me! Thanks!