• Similar Content

    • By ed100
      i have a 1999 lexus rx300- only cold air on driver sided, luke worm on passager side.
      the heat servo motor is working.
      passenger side air seems to be getting a little warmer but driver side is very cold. Fan works great.
       
    • By SteveoJo
      Any folks in the Northeast familiar with any auto electrical specialists I can take my RX to? 
    • By dabNebula
      So in the attached image you can see the list of dtcs I have on a 2000 rx 300 AWD
       
      I have tested coils and replaced spark plugs on 2-4-6, all should be in perfect shape.
      I have tested unplugging the coils I could easily access with the entire intake assembled, which seemed to not affect the idle, leading me to believe that perhaps those spark plugs in the back are no good.
       
      I am going to head back out now to work on getting to and replacing the 1-3-5 spark plugs, if I can manage. 
       
      1. With the intake and throttle body(s?) removed, is it worth any attempt to remove the o2 sensor from above? I tried from below several times, with PB blaster let to sit overnight, to no avail.
      2. As I was taking off the intake filter lid, I could swear that one of the two "vacuum" hoses directly behind it, may have been unattached. I followed the one that is attached and it seems to lead to the Fuel Injector rail for 2-4-6. With this logic, would it make sense that the other tube leads to 1-3-5 injectors, and all this could have been from the vacuum leak causing those cylinders to run lean/misfire?
      3. Is there anything else I should check while I have the throttle body's off (and cleaned up beautifully) like the MAF, etc? I do have a multimeter, but I have only tried using it a couple of times and am not 100% on which items to check for which values.
      4. Is there anyone here with any insight on what values to check on my Code Scanner's "Live Data"? I found a great OBD2 scanner, but I don't know how to use these tools to verify the fix...
       
      My plan now is to replace the 1-3-5 spark plugs, reassemple the intake, verifying all connections are made and see how she runs... but I will work at the o2 sensor or anything else possible, while it's apart.
       
      Thank you if you read this! I am new to the forum, as I just purchased this car for my wife, so thanks in advance, if anyone hears this!
       
      Steve

    • By Faizmz
      Hi guys
      I own a 2003 RX300 which never had given me any trouble so far. I had another driver telling me one day that I have no brake lights what so over. I thought it is just bulbs so I replaced the third light bulb and still no brake light.
      I did some search and discovered about the brake light module which located within the panel at trunk on the driver side as per this video:
      https://www.youtube.com/watch?v=2wdEh4SugCw
      It says that I could try a jumper solution at 2:48 which I did.
      This is when things get interesting. After I tried this, the brake light did come on when I stepped on the brake but I lost other lights (turn indicators, reverse and rear lights). 
      At the same time I also lost power windows and the heat.
      I tried soldering every component on the brake light module, thinking it might be bad connections but still I have the same problem (no heat, no power window, no rear lights except brake).
      The power windows make no sound what so ever, so my guess is there is no power flows through the system at all. Nothing also happened at the display when I pressed the climate control button. The display works as the radio and CD is on.
      My guess is this was caused by me jumping the connectors at the brake light module? 
      I checked the fuses with multimeter on the left side of the steering wheel inside the car and they all show continuity. Not sure if they are other way to check the fuses or maybe there are other fuses I should check?
      I can't be driving this car at the moment without heat (it is -20 here) as well no lights are working at the moment.
      I appreciate very much any help I can get with this!
      Thanks!
       
    • By FinallyFree
      Retiring at 68 and thinking of selling my Honda Odyssey and getting a true Luxury car; a Lexius.  Zeroing in on an older ES 350 or RX.  Maybe even a Hybrid one.
      So, I ask you experienced Lexus owners, is this a bad Idea for a single woman who can’t fix her own car?  And the closest Lexus shop is 2 hours away? 
       
      I’d like to keep the price around 25,000 or less.  
       
      Thank you for any insights, advice, etc
      Pam