ez12a

How to fix broken touch screen Lexus GS IS

Recommended Posts

Hey All, my navigation display stopped responding to touch. Here's a video on how I  was able to remove and successfully repair the screen:

 

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Nick Boltz
      Does anyone know if/when Lexus is releasing the 2018-19 navigation system update? I've searched all over the place, and the latest info I can find refers to the 2017 update.
      I have a 2015 RX350 with the original maps, and I'd like to update them as soon as the newer updates become available.
    • By RyGuy2484
      I just purchased a 2004 GX470 about a month ago.  It has the Marc Levinson sound system with navigation, cassette radio unit with a multi-disc player in the glove box.  When you push the Audio button the nav screen, all the screen says is "Audio Off" with no audio coming from the radio.  When my lights are on at night, I noticed the radio unit itself is not illuminated which makes me believe I have a power issue possibly to the radio unit. After some research, I did come across the Service manual for the radio ( http://www.clublexus.com/forums/att...-toyota_kex-m8527-kex-m8727_servicemanual.pdf ).  
      If I put in a destination in the navigation, you can hear the audible instructions.  If you push the other buttons on the nav screen, you can hear an audible tone at the press of the button.  However, when you push the audio button, it just gives you the message "audio off".  I brought a multimeter home from work the other night to check the power coming through the wiring harnesses and from what I could tell, I am not getting any power.  (***Side note - I know enough to be dangerous but I do not claim to be a technician by any means and most of my information is from some engineering friends and YouTube...).  I referenced the various pin positions in the radio service manual to know which ones to check.  I also checked with the vehicle key turned to ACC mode and then also checked with the engine running.  Both times, it didn't appear that I had any power coming through to the radio unit.  I also checked the fuses and they all seemed to be fine.
      I called one of the local car audio shops here in town that I received a good recommendation from and he basically said good luck and they wouldn't touch it with being OEM and knowing all the issues that the Marc Levinson system has had.
      Has anyone else seen this issue?  Any ideas on where the power would actually be coming from that feeds the radio head unit?  The wire schematic is included on the service manual but it's tough to make heads or tails of it.
      Thanks in advance for any responses.
    • By Carteak004
      I am able to listen to navigation and cursor sounds but cannot listen to music. FM, AM, Bluetooth or iPod, nothing is working Cannot turn volume up or down. Any ideas?
      55398162695__FAD5088A-ED4D-42F4-8ACE-493CE31EBAFD.MOV
    • By dolphinman
      Hey All
      I am looking for a navigation sd card for a 2104 Ct200h.  MIne was missing when I purchased the car.  The dealer said it must be ordered from Japan. (takes weeks if not months!!!)  There are several on Ebay ,but I am not sure if they are the correct one.  If anyone has a 2014 Ct200h or knows the correct number (number printed on the card it self) please let me know asap.
      I asked the dealer for the number from the card but all they would give me is the standard lexus part number.
      thanks for all your help
       
    • By 2007 is350
      Hey guys, I drive a 2007 Lexus IS350 with x-package. 
      My navigation screen suddenly went completely white. Just plain blank white. Everything still works though. The radio and everything functions. And even when you touch the screen itself you hear the feedback and noise that it's working. But the screen itself stays white and I can't see anything.
      Anyone know what the problem may be?