LS Max

FS NIB: F sway bar links, F lower ball joints, and F tie rod ends for 2000 LS400

Recommended Posts

I have brand new, in box:

     - Moog ES80291 Tie Rod End

     - Moog ES80290 Tie Rod End

     - Beck Arnley 101-4897 Stabilizer Link

     - Beck Arnley 101-4898 Stabilizer Link

     - MOOG K500213 Suspension Ball Joint

     - MOOG K500214 Suspension Ball Joint

I will match Amazon prices and eat the shipping (within continental U.S.).

I ordered these parts for my car but did not realize that I didn't need them until it was too late to return them.  I'm just trying to get most of my money back.

Bitcoin, Ethereum, Litecoin, Monero, or Z-cash accepted in addition to Paypal, Venmo, or Western Union.

Share this post


Link to post
Share on other sites

  • Similar Content

    • By Kaimana
      So, I'm still struggling with the coilover problem. I want to put stiffer suspension on the Lexus, but I don't want to screw up the camber, I haven't found any camber kits, so I'm curious if there's any way to solve this.

    • By Kaimana
      So, someone tried to break into my car and left my passenger side window in shambles and while looking for a new window, I discovered a 1999 model at U-Pull. Now this wouldn't be an issue if my car was a 1999, but it's a 1990. I'm wondering if the passenger window on that LS400 is compatible with my 1990 LS400.

    • By Kaimana
      I just bought a 1990 ls400, but I wanted to install some coilovers, but I'm worried about the camber. I don't want to stance my car, I just want it a little lower, but I can't find any camber kits. Any suggestions?

    • By SvpremeKai
      Hello everyone! I’m pretty new here, and before I ask my question, yes I’ve been throughout forums seeking answers and have tried a few things but now I feel as though I need advice. 
       
      Recently grabbed a ‘93 LS400 that’s been misfiring. I just had the alternator and belt tensioner replaced but the car did stall out on me due to very rough and low idle. Check engine code comes up for the mass air flow sensor and TPS, both of which were replaced and recently adjusted by my mechanic. I had heard that if the catalytic converters were glowing red that means that they were possibly clogged, possibly oil in the cylinders leaking(?). I’m not sure, I’m fairly new to these vehicles in general. 
      One thing to keep note of is, the check engine light is illuminated. When I give the car gas it shows major power loss, however halfway thru second gear the car starts to pickup/ maintain speed and the check engine light goes away. Once I come to a stop, or even let off the gas for a bit the CEL comes back. Complete stop brings the rough idle back. I did read that the ignition coils could be to blame as well. I changed the one dead center in the engine, but not the second one by the battery.
       
       
      My question is should I be weary of the cats? My plan was the yank them and simply straight pipe the car on back. However efficiency is all I want now considering I haven’t had time to even enjoy the car since I purchased it 😟 
       
       
      1993 LS400 
      188,114 Miles
       

    • By Pepdoesit
      New member here, I have a jdm 91 Toyota Celsior. Starter was making noise during start up so I thought it was going bad. One day car stop doing anything. I would put the key in and everything works but it won’t turn over. I figured it was the starter. I changed the starter put everything back together and still nothing. I tried a new starter relay still nothing. It has a brand new battery. All fuses are good including fuses user the dash. If I bypass the starter relay it will crank over but will not start. Uses the key does nothing. Came here to see if maybe someone can help me big thanks in advance.