Sign in to follow this  
vschopp

Engine Surging With A/c On

Recommended Posts

New to the land of SC's, recently purchased a 92 SC400 with 100k and have all of the classic issues IE lower control arms, ect. but there is a problem that I could use some expertise. Car runs great until I crank up the A/C. Car seems to run fine for awhile but then she starts surging even on the highway. Turn off the A/C and it stops surging. Car had 100k trip through a Lexus dealership and a tuneup was performed. I just changed the fuel filter as well to no avail. Anybody run into this....Thanks

Share this post


Link to post
Share on other sites

probably a bad bearing on the a/c pump. mine makes a high pitched whining noise when i turn the a/c and it definitely robs me of some power. im going to look for a rebuild or take the pump off because a new one i think is like 450 dollars.

Share this post


Link to post
Share on other sites

My AC makes a weird clicking noise inside the car. probably the little fan that pushes air threw the vents.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this