volosong

req help/advice - 2006 RX400H back windows inop, sometimes

Recommended Posts

I sold my 2006 RX400H to my best friend and she asked me to check the fuses for the power rear windows.  They do not go down or up with the driver's door switches.  I checked both fuses, and they were fine.  Checked the lock button on the driver's door next to the switches and it was "off".  Then I tried all four windows with the driver's door switches and both front windows go down and up; and neither rear window went down or up.  Then, I climbed into the rear seat, had my friend sit in the driver's seat, start the car; and I activated each rear seat window in turn - and both work just fine with the switches on the rear doors.  I immediately had her try again, and she could now control the right rear window from the driver's seat switches, but not the left rear window.

Any ideas?  Dirty switches in the driver's door?  Something else?

Thanks for any help you can offer.  (p.s. She really likes the car and wants to keep it for a long time.)

Share this post


Link to post
Share on other sites

Sounds like switches have dirty contacts...maybe just try it several times as you did to see if they start working properly

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...