pacolet

Pioneer radio issues 1994 LS400

Recommended Posts

My original Pioneer radio has developed several issues over a period of about 6 months or so...AM section is not working, only get a low level hiss, not static, at high volume setting and does not detect and lock in on a station, just keeps on scanning.  The radio plays fine on both FM settings but will not even try to switch, by push buttons, to either the cassette or CD modes, just stays on FM.  The antenna stays up too.  I checked for loose antenna wire for AM and the connectors on the back of the radio.  Any idea if these might be related to a single problem?

Share this post


Link to post
Share on other sites

I'm not sure, but over in the UK radio stations have moved away from AM to FM and even now are transferring over to DAB so possibly the radio stations are winding down the power on AM to put more power over to FM or DAB?   Just a thought !

Share this post


Link to post
Share on other sites

I listen to AM very rarely, I only mentioned that symptom in case it would be part of some multiple failure scenario with which someone here would be familiar.  This is a 1994 model radio so don't think it would receive DAB, anyway that's not the issue.  Thanks for your input.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...