Do Not Sell My Personal Information Jump to content

Mg Clt Relay Not Receiving Proper Ground - Help Please!


Recommended Posts

1999 Lexus RX300

My compressor cycled on and off a few times. Now, it will not come on automatically and my fans aren't working properly.

Here is some detailed info:

The vehicle was in a minor accident in which it went into a small ditch on the passenger side. The strut and fender were damaged and replaced. This occurred after the accident (to my knowledge...customer states AC worked before and I purchased the vehicle from him).

I can jumper the fan relays individually and they will kick on. I can jumper the MGCLT Relay and the compressor will kick on.

Per the advice of an expert on just answer, I replaced the compressor AND the ECU which did NOT fix the issue.

After further testing, I have realized that I have power going to both sides of the MGCLT Relay. It is not being grounded properly to kick on the compressor. To my understanding, the ECU grounds the Relay?

I'm hoping someone on here has a thorough understanding of how the AC system works and possibly diagrams that my help me figure out why it is not being grounded. Considering I have already changed the compressor and ECU, where could my problem lie?

Thanks in advance

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...