Jump to content


1997 (And All Other Years) Sc400 Ect Pwr Vs. Norm


m3chan1zr
 Share

Recommended Posts

I'm just wondering the differences between ECT PWR and NORM for you guys out there. I was reading on another forum and it said that when others put it into "PWR" mode, it constantly redlined the RPMs. My throttle response and shift points don't increase that highly that it goes all the way to redline, in fact, it just raises the shift points by a few hundred RPMs if that. However I didn't do a hard acceleration, just some normal acceleration in city & highway driving.

The speed limit on my local roads is 45, and I drive 50. On NORM mode, the RPMs stay below 2000 and shift at ~1900 all the time. With the PWR mode, it shifts at about 2200, way below redline. Maybe I'm just a "slow" driver. I accelerate just about as fast as everyone else though, usually faster. Even when accelerating to toll road speeds (speed limit 75 where I live), the car shifts at about 3000-3500 RPM, again still below the redline.

Anyway, I notice steering power assist is reduced (tighter steering), increased throttle response, and higher shift points.

I just wanted to hear your experiences with the two modes.

Thanks.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

I have a 1997 that is just going through an inspection, I will try the different positions and we can compare the differences soudn ok, will get back to you in about a week...

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Sorry for the late reply, I have been out of town lately. Anyway, thanks! I look forward to what you find. The only differences I noticed are increased throttle response, different shift points, and a tighter steering. No doubt you've been busy yourself. Thanks again.

Link to comment
Share on other sites

Hey Brandon,

Tried out the Power Switch and yup goes to redline before shifting into the next gear, road was a little damp and just starting spinning the tires before getting enough traction to get out of the gate....must be something wrong with yours if it isn't taking it up to 6200 RPM before shifting into the next gear.....

Link to comment
Share on other sites

Hey Brandon,

Tried out the Power Switch and yup goes to redline before shifting into the next gear, road was a little damp and just starting spinning the tires before getting enough traction to get out of the gate....must be something wrong with yours if it isn't taking it up to 6200 RPM before shifting into the next gear.....

Alright, I'll mess with it tomorrow. I didn't push the pedal to the floor as I don't do that usually. I was surprised to hear in normal driving it goes to redline. Does everyone push the pedal all the way or something? lol. Anyway, I'll do a hard acceleration tomorrow and see how it goes. Thanks for your reply.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership