Do Not Sell My Personal Information Jump to content

Recommended Posts

I just bought my car yesterday. However while driving home from L.A. to Northern California (after 5 min), my location was totally off?? It looked like the GPS system was not picking up the signal. I stopped the car to manually calibrate, and it work for only a few miles, then lost again. A day later and it's still not working. Is there supposed to be a "GPS" icon on the top left corner (shown in the manual)? Please help!!! I plan to bring it back to the dealer to fix it. Is anyone having this problem? Other than that, the car is great.

Link to post
Share on other sites

yes, there's only the "direction" icon on the top left corner. Should there be a "GPS" icon below that? That's what the manual says and I also see it in my friends 2002 RX300. Did they change the format for the 04 GX models or is yours also a 04? Thanks.

Link to post
Share on other sites

Under the North-Up and map scale rectangle, there should be another rectangle. Inside that rectangle, you should see "GPS", indicating there is a signal being received by the navigation system. My truck is a 2004.

Link to post
Share on other sites

Have you placed anything on the dashboard or instrument panel that doesn't belong there? Have you had the windows tinted? I picked up my truck this afternoon after having all the rear windows tinted dark and the driver/front passenger windows tinted medium. Non metallic film was used, to avoid disrupting antenna reception.

Link to post
Share on other sites

The GPS antenna is bad. The No Cal. dealer placed an order and should get it in a week.

I am p-off at the So Cal. dealer that I purchased the GX from. They should have checked it before delivering the vehicle. Also, I think they knew something was wrong but couldn't figure it out, but they just delivered it anyway. They just manually calibrated it so it would for a few miles. I found out about the problem after leaving the dealership.

Link to post
Share on other sites

You should have received or will receive a corporate Lexus, new car customer satisfaction survey. That will be your chance to really ding the dealership. The dealer should also have provided a signed checklist indicating the car was completely prepped and operational at time of delivery.

Link to post
Share on other sites

They replaced the antenna and it works fine now. The pleasanton dealership was great. However the auto headlights do not work. They don't turn on when it's dark. Also the side driver panel is not sealed properly (pretty minor) I hope these are the last problems. I am getting to know the service people a bit too well :D

Link to post
Share on other sites

Well, it's good to hear that your navigation is working. Yesterday, a tennis friend was riding in my truck and was VERY impressed with the navigation display, dash layout, quality of interior materials and the smooth ride. He drives a 2004 Mercedes S55 AMG. AMG translated means 493 HP, 516 FT-LBS torque, 0-60 in under 5 seconds and $111,000. I am impressed that he is impressed :o

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...