Jump to content


Alternator Issues


dluebbe
 Share

Recommended Posts

Any guesses as to what could cause me too go through 4 alternators in one year on my 92 ls400? It had a power steering leak with the first one then I fixed the power steering pump and replaceed the alternator then I have just recently went through three more. Any answers or opinionswould be greatly appreciated I really wanna fix this problem

Link to comment
Share on other sites


Dshawn, welcome!

Well, I can take guesses as to why they failed. The first guess is that the alternators are cheap and fail early. Or just got a bad streak of luck. Not likely.

The first thing that I would want to know is who decided that the alternators were bad? A mechanic? Did he/she do a teardown to find out what, exactly, failed within the alternator? I would guess that you are buying "lifetime" alternators from a local autostore?

Here is what I would do. With a new or rebuilt alternator installed and operating, I would check the charge voltage. Perhaps it is way too high and causing undue load on the alternator thus causing it to fail early. If the voltage looks ok (13.5-14.5VDC) then I would check the charging current. There could be an excessive amount of current draw on some load within the car which is causing the alternator to overheat and burn out early. Sometimes, I have seen a bad battery keep working but draw a lot of current to charge it. I would have a suspicious eye on the battery.

My bottom line guess is that there is an excessive load on the alternator for some reason and that is burning out the diodes in the alternator. You might consider a high-quality Denso alternator with 100 amp (or more) output capability. But other alternators should not be failing so early. Check those parameters that I mentioned (voltage and current draw).

Link to comment
Share on other sites

Any guesses as to what could cause me too go through 4 alternators in one year on my 92 ls400? It had a power steering leak with the first one then I fixed the power steering pump and replaceed the alternator then I have just recently went through three more. Any answers or opinionswould be greatly appreciated I really wanna fix this problem

Is your battery stock ? (not likely), What's the battery power? The last one I replaced after I bought my LS was 650w, the new one is 800w and runs fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership