Jump to content


How To Fix Navigation Error - Incorrect Program Disc


BzowK
 Share

Recommended Posts

Good Evening All -


I recently bought a 2003 GX470 which I like much more than the X5 I had prior to it. The only issue with it was that the GPS reception didn't work even though the antenna was plugged in. I found the secret screen and made the big mistake (didn't know at the time) of choosing to load a program like US-XXX in an attempt to fix it.


Now, when I turn my car on, I get a screen (1/2 English & 1/2 Japanese) saying"Error; System unable to access the program" followed by "Incorrect Program Disc. Please insert proper disc."

car1.png


I've searched all over this forum and others as well as tried a few fixes - all without any luck. Below is what is happening in more detail as well as what I've tried already to fix the issue.


The Issue in Detail

When I turn the car on, the display shows the Lexus logo for a couple of seconds, a screen saying "Please wait while the system updates for about 3 seconds (if I have any disc but the original DVD in), then the error message above.


The Map, Navigation, and Menu buttons do not work (show the message,) but Display, Audio, and others do work.


The car came with an original 3.x (I think) version maps disc. It's a Gen 2/3 unit. I purchased the 10.1 and 13.1 upgrade discs and have copied them to DVD-DL which I am using to keep the expensive retail discs unharmed. Upon purchasing the 10.1 disc, I put it in which updated the system (about 5 minutes) but kept getting disc unreadable messages (even with OEM one) so went back to older maps disc. Just got 13.1 in this week to try to fix this issue but do not believe it's installed / updated properly yet.


What I've Tried

Inserting new maps version disc to upgrade

When I do this, it does not fix the issue. The only difference is that after showing the Lexus logo, the screen shows "Please wait while system updates" for about 3 seconds (each time i turn it on) and then goes to error. I got the same results with versions 10.1 and 13.1 discs so tested and found out that it shows the same "Please wait..." message even if an audio CD is in the drive :)

(Pics at end of post)


Resetting NAV Unit via Battery Backup

After reading a post (on this site, i think) I removed the NAV unit / DVD drive from the bracket under my passenger seat. I opened it up to reveal the drive as well as the battery backup (with yellow border.) The instructions said to drain it with a light overnight. I simply removed the battery for about 5 minutes. I re-assembled it and hooked back up. No change at all

The next night, I opened it back up and drained the battery via light method as well as leaving the battery out overnight. I reassembled and still no go when trying to Original, 10.1, or 13.1 discs.


Below are pics of the NAV Unit I removed. Included are the cables connected to it and model number. Is this the box I'm supposed to do this to or is there another?

(Pics at end of post)


Resetting NAV Unit via Ribbon Cable

I've read that units may be reset by unplugging a ribbon cable for a few seconds - but - don't know if this pertains to my unit or not as the ribbon cable was difficult to get to and seemed to be the drive data interface. Still, removing the battery should have had the same effect. Perhaps I'm doing this on the wrong box?


Another Secret Menu

I cannot currently access the secret menu I had previously where I made the stupid mistake. I did find out about another today, though. Holding down the Info button, turn the lights Off, then On 3-4 times. Unfortunately, this menu doesn't have the same options therefore I can't change anything back (even if I knew what to change it back to.) It does have a "NAV Reset" option, but it's greyed out.


So - that's where I'm at. I can't afford $1000+ on new hardware and would really hate to do so. Any suggestions? I'm willing to try anything to fix this!


Thanks!


Pics

car2.png

car3.png

car4.png

car5.png

Link to comment
Share on other sites

Hi Ben and welcome to the Lexus Owners Club.

Well upfront, I am not going to be of much help. But this is my "for what it's worth" column.

Fear not for things are not beyond repair. The major problem with all first generation Nav. systems was providing a consistant, smooth, platform for on going software updates. Obviously, as your experience has proved, that smooth upgrade path is still a work in process.

Since you've already done a lot of research, I would take a differant direction and contact your Lexus dealer. Here's why. Lexus .should have the ability to reboot the system and clear the old and new software its trying to do a Vulcan Mind Meld with. Lexus should also be able to load the current release for upgrade Nav. Yes, people will tell you that Lexus is exspensive. My response is if I can solve the problem in the correct manner. at one appt. with factory training., and then be able to have a place where I can go back to for questions and ongoing support.

Thats my two cents,

Paul

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership