Jump to content


Trouble Replacing Antenna


FlyingDrummer
 Share

Recommended Posts

I was able to remove the old antenna using the AM+DISC buttons, and it seemed to come out fine, with no cable left in the motor. The bottom segment of the antenna came out separately. When I try to insert the new antenna, I can only get about 10-12" down before it stops. Comparing the new antenna to the old, it looks like all of the parts came out.

Any ideas?

Link to comment
Share on other sites

  • 2 months later...

Hello FD,

This is a late reply and hopefully you have sorted this out. If the procedure to install the antenna is being followed correctly, it sounds like an obstruction.

Don't know if you found this great tech service bulletin, but I will post a link here if not for your benefit, for anyone else who might need it. This really helped me get the job done with minimal angst. The instructions are for the 2002 SC. I actually have an '04, but the instructions worked fine, and it is my understanding that this holds true for several model years, though I can't vouch for sure on the '05.

http://www.galvincom.com/views/41152-299153d1380247224-new-antenna-making-a-grinding-noise-sc-antenna-replacement/

Cheers.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership