Do Not Sell My Personal Information Jump to content

Driver Side Seat Motor Question


Recommended Posts

Every power option on my SC400 drivers seat works except the back. When you move the switch either way you can hear a click. Is this a bad motor. Is the motor for the back a separate motor? Could it be jammed.

Also, with the manual lever, how far should the seat go back, it won't go back at all hardly. Should it fully recline.

Thanks!!!

Link to post
Share on other sites

Okay, you've suffered long enough!

The lever is strictly for tilting the seat forward.

If you are hearing a clicking sound when you actuate the tilt lever, then your motor is working, you have a problem with the motor drive system. You may need to remove the seat and determine if the gear drive for the motor is stripped.

Can you sit in the seat and put pressure against the seat back as you try to tilt the seat backwards. This might get the motor off the stripped tooth that it may be hung on.

Good Luck!

:cheers:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...