Do Not Sell My Personal Information Jump to content

Recommended Posts

My antenna stopped going up and down when I turn my radio on and off. I can hear the motor still running though. Should I get a new/different antenna or what? Can I fix it without having to purchase another antenna? Any help/suggestions would be greatly appreciated. I have a 1996 GS300. :rolleyes:

Link to post
Share on other sites

Depending on your skills, you can replace antenna or replace the plastic mast inside that breaks over time. The dealership should have the plastic mast piece, or you might find it online cheaper. New antenna is straight forward and not that hard if you are mechanically inclined. If you have a gold package you probably won't be able to reuse the gold nut on top of the antenna, unless you get a factory antenna. Most replacement come in chrome.

Link to post
Share on other sites

I just did the replacement on my 93 GS300. Get the stock replacement antenna off of Ebay (do a search) about $20. Follow the instructions and your done if 10 minutes. If the plastic internal cord is broken, like mine was, you have to do a bit more work to remove the broken part from the motor case, then reinstall. That took about and hour to complete. Now it works great! Don't go rubber. It looks ok, but does not retract and gets bumped crooked all the time. ;)

P.S. Here is the link:

http://cgi.ebay.com/ebaymotors/ws/eBayISAP...&category=33639

Link to post
Share on other sites

  • 6 years later...

I just did the replacement on my 93 GS300. Get the stock replacement antenna off of Ebay (do a search) about $20. Follow the instructions and your done if 10 minutes. If the plastic internal cord is broken, like mine was, you have to do a bit more work to remove the broken part from the motor case, then reinstall. That took about and hour to complete. Now it works great! Don't go rubber. It looks ok, but does not retract and gets bumped crooked all the time. ;)

P.S. Here is the link:

http://cgi.ebay.com/ebaymotors/ws/eBayISAP...&category=33639

I've got the replacement unit, but no instructions. Talk me through it, and I'll photo document the steps and post for everyone's benefit.

Link to post
Share on other sites
  • 3 months later...

I just did the replacement on my 93 GS300. Get the stock replacement antenna off of Ebay (do a search) about $20. Follow the instructions and your done if 10 minutes. If the plastic internal cord is broken, like mine was, you have to do a bit more work to remove the broken part from the motor case, then reinstall. That took about and hour to complete. Now it works great! Don't go rubber. It looks ok, but does not retract and gets bumped crooked all the time. ;)

P.S. Here is the link:

http://cgi.ebay.com/ebaymotors/ws/eBayISAP...&category=33639

I've got the replacement unit, but no instructions. Talk me through it, and I'll photo document the steps and post for everyone's benefit.

mine has the exact same problem.

lkelso, did you end up fixing yours?

Link to post
Share on other sites

$8 at Advance Auto, retracting antenna without the fuggen motor! For some reason most auto makers thought it was a luxury to have a motorized antenna in the '90s. I've owned Lincolns, Jags, etc, and the antenna always breaks. A manual antenna works fine, can be retracted for carwashes, not sure why you'd want it to retract any other time. No more motorized antennas in the last few years, now they're integrated into the windows or elsewhere.

Lex

I just did the replacement on my 93 GS300. Get the stock replacement antenna off of Ebay (do a search) about $20. Follow the instructions and your done if 10 minutes. If the plastic internal cord is broken, like mine was, you have to do a bit more work to remove the broken part from the motor case, then reinstall. That took about and hour to complete. Now it works great! Don't go rubber. It looks ok, but does not retract and gets bumped crooked all the time. ;)

P.S. Here is the link:

http://cgi.ebay.com/ebaymotors/ws/eBayISAP...&category=33639

I've got the replacement unit, but no instructions. Talk me through it, and I'll photo document the steps and post for everyone's benefit.

mine has the exact same problem.

lkelso, did you end up fixing yours?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...