Sign in to follow this  
Hoyrodd24

Sound Upgrade Choices...

Recommended Posts

Hi I have a 05 RX330 I had the JVC kw nt30hd navigation head unit installed with the beat sonic amp integration. It sounds better. But now I bought two Polk audio DXI series 6.5 components as well as two 6/9s. And a Kicker 4channel amp.

We are going to let the head unit power the dash speakers and the other six(tweeters included) on amp. My question is has anyone upgraded all the factory speakers with an amp and if so was the sound better? And if so how much better would you say..? The factory speakers sound great currently with the new stereo so I was wondering what to expect. Thanks!

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By BeachBumForever
      2003 ES300 - 209,000 miles
      I have developed a "clunk" that seems to be coming from the passenger side trunk area when hitting a pothole or pavement change. First thought is a strut or mount going/gone bad so will probably replace all 4 struts. Need suggestions on whether to use OEM parts or aftermarket parts and sources. I prefer a smooth ride versus performance handling. Suggestions on the parts and process appreciated. Should the struts be replaced BEFORE or AFTER a full alignment? The work will be done by a shop, not by yours truly.
    • By zcoco300h
      Just bought a sweet used 2013 ES 300h which I love however the stock stereo is underwhelming. Coming from an '09 Camry Hybrid with a JBL package (which was pretty good, great bass).
      This is the nicest car I have owned so far and I would like to avoid putting an actual sub and amp in the truck and dicking around with wiring etc. I would like to get alittle more bass out of the system though and hope that this can be done by upgrading the rear deck woofers.
       
      Any ideas/ past experiences etc...?
       
      Thank you!  
    • By Supradi
      Selling 4 used stock wheels and tires from my LS400. These must go like yesterday. Only asking $150, local pickup only (DC, MD, VA area)

    • By 04lexusrx33O
      Hello! My name is Jake and I have an 04 RX330 with 230,000 miles on it. Not certain on the history of it but I have gotten it with no heat and an overheating problem(EDIT: previous owners said it has overheated on them). I immediately knocked out the easy stuff, checked coolant levels, verified fans were working. So I end up doing serious work that it needed: waterpump, timing belt, power steering pump, upper/lower intake gaskets, thermostat(THM 117-$11.32 at napa), valve cover gaskets, spark plugs. I end up finding smoke swirling out of a crack in the radiator while the car was idling for an hour during a fuel injector decarbonizing process. I end up replacing the radiator as well as the fan motors with the relay because the fans wouldn't turn on. I ended up using a power probe straight to the old fan motors and only fan #2 worked. I end up putting it all together-bled all of the air out of the cooling system with an airlift evacuation tool-and this thing is still overheating! Today I pulled it in and put the scantool on it-temp reads 244 degrees, so it's up there. I take a laser thermometer gun and the passenger-side (or upper hose) of the radiator read 183 degrees give or take and the part of the intake that the sensor screws into was around the same. So I thought it's only a $20 sensor, and replaced it-also considering it had a previous P0117 code(engine coolant temperature circuit low input). I know when the DTC is aiming at the input part of a circuit, it's talking about something with the sensor. I thought this would do it, BUT the car still overheats via gauge. Good news was I had heat, so I'd blast it when it starts climbing up and it'd slowly go down. I'm really stumped now, because I know the heater core acts as a mini radiator, but it doesn't make sense that the heatercore cools the engine down but not the fans and radiator being fully functional. The upper heater hose is piping hot with pressure but the lower hose is room temperature with pressure, I verified by squeezing the hoses. Is the thermostat defective? I installed it with the wobbler pin positioned at the top via installation instructions. I feel like I might run a compression test tomorrow to check the head gaskets, but I feel like I'm missing another sensor or something-I'm a freshman in college so anyone with experience I'd greatly appreciate it! 
    • By matthewlswanson
      My guess would be either the first gen rx300 or the most recent gen rx350 because they have the most ground clearance. Not sure how they all compare with locking diffs, gearing, wheel articulation, low end torque, etc since I only own the first gen. 
      Second question: is the RX a lot worse off road than the LX and GX or are they close?