Sign in to follow this  
aportinga

Hic - Up: Acceleration

Recommended Posts

New Member here - Hi all.

We have a 1991 Lexus LS400 which hic-ups frequently. This does not occur while the transmission is changing gears but instead randomly. Once and awhile the car will bound the revs and at times it will even die.

We just replaced the battery and the fuel filter (not orginal Lexus parts however).

Any suggestions before I bring old Big L in and drop a grand.

Share this post


Link to post
Share on other sites

sounds like you have a bad plug if its misfiring. its probably not getting a good enough spark in one of the cylinders. try replacing your plugs. if that doesn't work you need to look at changing, plug wires, distributor cap, make sure all vaccum hoses are on correctly. but it definately sounds like something in the ingnition. good luck

Share this post


Link to post
Share on other sites

have to agree, its either a bad plug or a wire. or both, might give u weak spark

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this