Do Not Sell My Personal Information Jump to content

Battery Light On


tabathadamien
 Share

Recommended Posts

I have a 1990 ls 400 and we done replaced the altenator twice and the battery six times and the battery light is on now and wont go off checked all fuses all is ok what is wrong and why wont it go off?now driving the car, it is pulling really hard like the traction is off.have to drive really slow to make it home. leaking anitfreeze near the thermostat and powersteering. any suggestions would be really helpful. please help we now have two cars broke down and i need one of them to work.

Link to comment
Share on other sites


now driving the car, it is pulling really hard like the traction is off.have to drive really slow to make it home. leaking anitfreeze near the thermostat and powersteering. any suggestions would be really helpful. please help we now have two cars broke down and i need one of them to work.

Link to comment
Share on other sites

is that the belt that goes around the fan and altenator and eveything else? if so it is not broke could it be something else? also i just called oreilly's part store and they said that not all altenators fit the car what one do i need?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership