Do Not Sell My Personal Information Jump to content

1994 Ls 400 A/c Issue


Larry W
 Share

Recommended Posts

I had the A/C on my 94 LS 400 serviced yesterday. The compressor, clutch, & evaporator were replaced about 6 months ago when it was cooler than the 100+ degrees now here in Fort Lauderdale. I noticed that the air was not quite cold enough coming out of the center vents. The right passenger vent was not even close to being cold. The local

repair shop said that vent is the furthest from the evaporator. The sight glass was foggy so I knew something was not right. A determination was made that there was air in the system and a pump down and recharge was required. I had the service performed and it felt a little colder. Not anywhere near my wife's Avalon (could hang meat in her car). The mechanic said the sight glass was "clear". It is colder, but not as cold as I think it should be. I'm in and out the car all day long on appointments so I know what it should feel like. The mechanic did say the heater control valve was defective (could see the white build up below the valve). Any suggestions?

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership