Do Not Sell My Personal Information Jump to content

2006 Nav System Problem


Diceguy
 Share

Recommended Posts

My 2006 RX330's nav system has recently developed a problem that has gotten worse over the past few weeks. Symptoms: while driving, the system momentarily shuts down, resets, and then continues. This entire process only takes a second or two, and does not interfere with the operation of the vehicle, but it is annoying. For one thing, the "resetting" of the system closes the Bluetooth connection to my phone rendering the hands-free use of the phone useless. Secondly, sometimes the new screen display is something I never originally set - like the "Trip Maintenance" screen or in one case a minimal "Climate" screen (displays fan only, no other climate settings).

I hate to take the car into the dealer for something that doesn't prevent driving it - especially since they charge a ton simply to look at the problem. I'd then expect the repair bill to also be outlandish. Does anyone have an idea of what is wrong and how to fix it?

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership