Do Not Sell My Personal Information Jump to content

Inaccurate/erratic Speedometer 2000 Lexus Es300 - Please Help


 Share

Recommended Posts

My speedometer will slowly creep up to around 60 mph, then stay "stuck" there until there is a significant reduction on speed. Then the needle will quickly jump down to the "correct" speed. My guess would also be that whenever I exceed 60 mph the needle simply stays and will not move until I actually hit 60 mph again. At that point the speedometer "catches up" with the correct speed again at around 30 mph.

This is what still works in my car:

- Odomoter works normal (on actual and trip A and B mileage)

- Cruise Control

At this point the problem (my guess) could be the vehicle speed sensor (VSS, still trying to find the location of it) or the instrument cluster itself. I have yet to check if the car shifts into 4th gear (I believe it does). I also want to note that a dealership 2 owners ago left a GPS tracker which is behind my coinbox. It is still wired in, active, with the light blinking. I wonder if this unit could be throwing my instrument cluster off?

ANY SUGGESTIONS/COMMENTS ARE GREATLY APPRECIATED!!!

Link to comment
Share on other sites


My speedometer will slowly creep up to around 60 mph, then stay "stuck" there until there is a significant reduction on speed. Then the needle will quickly jump down to the "correct" speed. My guess would also be that whenever I exceed 60 mph the needle simply stays and will not move until I actually hit 60 mph again. At that point the speedometer "catches up" with the correct speed again at around 30 mph.

This is what still works in my car:

- Odomoter works normal (on actual and trip A and B mileage)

- Cruise Control

At this point the problem (my guess) could be the vehicle speed sensor (VSS, still trying to find the location of it) or the instrument cluster itself. I have yet to check if the car shifts into 4th gear (I believe it does). I also want to note that a dealership 2 owners ago left a GPS tracker which is behind my coinbox. It is still wired in, active, with the light blinking. I wonder if this unit could be throwing my instrument cluster off?

ANY SUGGESTIONS/COMMENTS ARE GREATLY APPRECIATED!!!

my guess is that your speed sensor needs to be changed ,nothing wrong with cluster or so ever.i dont have enough info about its location.hope this will help

all the best

n.b: it's a very easy fix as i had the same problem 'n took it to a garage and done it in half an hour

Link to comment
Share on other sites

@Hazouma: Thanks for your input. I checked for the vehicle speed spensor (VSS), even had a Lexus repair shop check for it, the place where it is supposed to be is closed off with a plate, odd. No clue how speed is transferred to the speedometer. Looks like some models have them, others do not.

I pulled my instrument cluster, took it apart. I moved the needle with my finger and it kept sticking at around 80 and I had to manually ove it back. Maybe the screws in the back were too tight, who knows. Still not sure why it did not go above 60, it at least moves more smoothly now, will road test tomorrow and post results.

Link to comment
Share on other sites

MYSTERY SOLVED (a least for my case): I had the GPS tracker removed, no impact. Needle would still not move at any speed above 62. I took the instrument cluster back out, took it apart, manually moved the speedometer needle, it stuck at around 70 and would not return to zero. Apparently the last time I took the instrument cluster apart I tightened the case screws too much since the needle moved freely depending on pressure of the spedometer back plate. Re-assembled instrument cluster, everything seems to work fine now, will probably do another speed test.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership