Do Not Sell My Personal Information Jump to content

Recommended Posts

Hi,

similar prob to many, ac works for a while, gets warmer and then doesn't work at all. based on search this seems to be the expansion valve problem

several question for any out there who might be familiar w/ this problem, before trying to do the replacement.

1. i've noticed that when running ac, the car idles ok at 750, but if i turn off the ac the idle drops down to about 500. if i restart car with ac off, the idle sits nicely at 750. i know there's an ac idle up switch somewhere, that may be a problem (altho i'd expect the reverse prob, i.e. idle dropping if ac kicks in...) could this prob be causing the ac to stop working vrs the expansion valve?

2. it appears from the manuals i have that the evaporator can be removed by first taking out the glove box, then the blower motor then sliding out the evaporator w/ valve. has anyone done this and can you provide any advice on this job?

3. i believe my '94 runs w/ r7 -- based on my not being able to connect r134 hoses to recharge, but there is little info about which coolant the '94 uses, anyone know for sure?

LL

Link to post
Share on other sites

so change the EV then...the parts are not expensive...My compressor is going but I leak tested with nitrogen, vac'ed out and installed oil and R134...Works mint and the issue is there was a leak at the dryer (based on oil around fitting) and leak testing.

But I would leak test it first...Compressor opertaing? ...Not much to an AC system at all.

Link to post
Share on other sites

compressor works fine, but shuts down after about 20-30 minutes.

ya, think I will do the valve and see if that fixes things.

just wonder if any one has pulled an evaporator before and if so, how long a job is it, etc.

LL

Link to post
Share on other sites
  • 5 weeks later...

The rest of the story.

I continued to "sweat" it out over the last few weeks. Noted idle dropping became more noticable over time, as the ability to cool decreased. Finally when it was idling, I saw the compressor and/or clutch seize, dragging the belt over the pully leading to idle drop.

So decided to dig in and replace both expansion valve and the compressor. Got a good deal from rycompressors in FL, just less than $300 for these parts plus a drier and shipping.

I spent an hour or so one night going back through the archives and found a very good step by step description (from 2007) of how to get the evaporator out to replace the expansion valve. It involves some spelunking under the passenger side dash, took me about 1 1/2 hrs to get the evap/expansion valve out, but 3 hrs to get it back in -- things are tight.

Flushed each line, and replaced all the orings (napa has a good selection..) then put it all back together. Down to the local mech to get it evac'd and recharged.

Now it's real cold!

LL

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...