Do Not Sell My Personal Information Jump to content

2004 Gx 470 No Audio


Amcb
 Share

Recommended Posts

The power button turns on the audio deck, radio, cd tape all show working but no audio through speakers. It was intermitten,t now not working at all. Audio selection on nav system and select sound no bars show up for balancing levels.

Is this a amp problem? If so does any one have spare parts and some instruction on replacement?

Does anyone know the part #?

Link to comment
Share on other sites

The power button turns on the audio deck, radio, cd tape all show working but no audio through speakers. It was intermitten,t now not working at all. Audio selection on nav system and select sound no bars show up for balancing levels.

Is this a amp problem? If so does any one have spare parts and some instruction on replacement?

Does anyone know the part #?

Sounds exactly like the amp. You can contact "dcfish" On this board for a new one.

In the future, the GX forum would be the best place to post a problem like this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership