Do Not Sell My Personal Information Jump to content

Recommended Posts

Hi everyone, well this time i thought my alternator was seriously shot. The guy who apparently replaced the power steering pump didn't do something right and there was some power steering fluid in the alternator. Well i thought it was shot so i switched out my alternator with the stock one i had that i used for about 2 or 3 months. The problem still persists the alternator wont charge. I checked all the fuses and replaced the cartridge fuse for the alternator. Any ideas people? TIA Joel

Link to post
Share on other sites

Hi everyone, well this time i thought my alternator was seriously shot. The guy who apparently replaced the power steering pump didn't do something right and there was some power steering fluid in the alternator. Well i thought it was shot so i switched out my alternator with the stock one i had that i used for about 2 or 3 months. The problem still persists the alternator wont charge. I checked all the fuses and replaced the cartridge fuse for the alternator. Any ideas people? TIA Joel

Joel, tell us a little of how you checked the charging system to determine that the battery is not being charged? Did you use a voltmeter and, if so, what were your readings? If you go about troubleshooting methodically, you can get to the root cause fairly straight-away. With speculation, its a crap-shoot.

Here is a list to follow -> http://www.lextreme.com/alternator.html

Link to post
Share on other sites

I took the car to autozone and when they connected that little battery and alternator tester they said there wasn't a current coming from the alternator. I can also tell my lights are very dim. And while I was driving one day it jus happened and my music got quiet. I also the telescopic wheel went up very slowly when I got out of the car. I'll try to check it again today. I'd hate to take it to an electrical shop. Thanks for the advice.

Link to post
Share on other sites

I took the car to autozone and when they connected that little battery and alternator tester they said there wasn't a current coming from the alternator. I can also tell my lights are very dim. And while I was driving one day it jus happened and my music got quiet. I also the telescopic wheel went up very slowly when I got out of the car. I'll try to check it again today. I'd hate to take it to an electrical shop. Thanks for the advice.

Well, AZ is a first step but do not put much stock in what they tell you. If you want to nail this quickly, get a voltmeter and go through ALL of the steps for checking the system as outlined in the lextreme link. Take good notes and do not skip any tests. Then get back to us with the results and we can go from there.

Link to post
Share on other sites

Oh btw i remember seeing a thread on here that talked about making a cover for the alternator so the power steering fluid won't drip on it. I can't remember exactly how it was made though. I just need it for temporarily.

Link to post
Share on other sites

Oh btw i remember seeing a thread on here that talked about making a cover for the alternator so the power steering fluid won't drip on it. I can't remember exactly how it was made though. I just need it for temporarily.

I believe it was just a cut-out plastic gallon milk jug.

Link to post
Share on other sites

Don't do the shield. You risk overheating the alternator resulting in diode failures on the stator plate or the regulator electronics will fail.

The root cause is a fluid leak. Fix the root cause. Fix the leak.

Link to post
Share on other sites

Well if its a hazard I'll just replace the power steering pump myself. Last mechanic i took it to said he fixed it, but its still leaking.

Probably not pump but the ACV in the PS pump. Many threads on this. Can be as simple as installing a plug to cap it off..

Link to post
Share on other sites

Well the hose that goes from the pump to the intake manifold is very flimsy. It will crease after a few minutes of driving and you can tell a huge difference in the power steering. Could that vacuum line cause the problem?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...