Do Not Sell My Personal Information Jump to content

O2 Sensor? Can Someone Please Help This Chick?


Melgs300
 Share

Recommended Posts

So I know nothing about cars I'm not gonna lie my car 2 weeks ago started loosing power slowly and then the steering wheel would shake really bad I would also have a burning smell coming from the hood the car would also feel like it was loosing power. I took it into a shop they thought it was the serpentine belt but after checking everything 2 times found nothing wrong with the car. i took it the following week after it did it again to the lexus dealership they said it was my o2 sensor and charged me 450 bucks to get it fixed saying it was the problem. okay so that was 2 weeks ago for the pass 3 days my car has been doing it again it will do it when my car stays at about 45mph to 50 steady. If i slow down or stop at a red light and go again it stops for a little bit then starts once i am at a steady 45 50. Any ideas? I dont believe it was the o2 sensor and dont feel that they fixed the right problem and now they said to bring it back in and I know they will charge me alot more again to fix the problem i specifically wanted fixed in the first place. Please help! btw its a gs300 with 107k

Link to comment
Share on other sites

I would suggest you find an independent mechanic that specializes in Toyota/Lexus vehicles. It is difficult to attempt to diagnose a problem like this through the forum since there are so many different possible causes. It doesn't sound like the oxygen sensor was the cause of the issue you are describing- but those commonly need replacement between 100-150,000 miles on any car so it may have been a totally seperate issue.

Figuring out the cause of problems like this is usually easy work for a trained mechanic who is familiar with the car. 107,000 is not a lot of miles- I would imagine this is probably something simple that was caused by lack of/improper maintenance in the past. Independent mechanics are usually much less expensive than the Lexus dealership so I think one of them would be the best place to go next. Best of luck.

Link to comment
Share on other sites

So I know nothing about cars I'm not gonna lie my car 2 weeks ago started loosing power slowly and then the steering wheel would shake really bad I would also have a burning smell coming from the hood the car would also feel like it was loosing power. I took it into a shop they thought it was the serpentine belt but after checking everything 2 times found nothing wrong with the car. i took it the following week after it did it again to the lexus dealership they said it was my o2 sensor and charged me 450 bucks to get it fixed saying it was the problem. okay so that was 2 weeks ago for the pass 3 days my car has been doing it again it will do it when my car stays at about 45mph to 50 steady. If i slow down or stop at a red light and go again it stops for a little bit then starts once i am at a steady 45 50. Any ideas? I dont believe it was the o2 sensor and dont feel that they fixed the right problem and now they said to bring it back in and I know they will charge me alot more again to fix the problem i specifically wanted fixed in the first place. Please help! btw its a gs300 with 107k

TA makes some good points. The only thing I would add is that since you paid for a problem that was not fixed, the dealership should cover some of whatever cost there might be to fix the actual problem. i.e., reduced labor or waived labor. I know that is the case with my dealer. It doesn't cost to ask.

Paul

Link to comment
Share on other sites

So I know nothing about cars I'm not gonna lie my car 2 weeks ago started loosing power slowly and then the steering wheel would shake really bad I would also have a burning smell coming from the hood the car would also feel like it was loosing power. I took it into a shop they thought it was the serpentine belt but after checking everything 2 times found nothing wrong with the car. i took it the following week after it did it again to the lexus dealership they said it was my o2 sensor and charged me 450 bucks to get it fixed saying it was the problem. okay so that was 2 weeks ago for the pass 3 days my car has been doing it again it will do it when my car stays at about 45mph to 50 steady. If i slow down or stop at a red light and go again it stops for a little bit then starts once i am at a steady 45 50. Any ideas? I dont believe it was the o2 sensor and dont feel that they fixed the right problem and now they said to bring it back in and I know they will charge me alot more again to fix the problem i specifically wanted fixed in the first place. Please help! btw its a gs300 with 107k

TA makes some good points. The only thing I would add is that since you paid for a problem that was not fixed, the dealership should cover some of whatever cost there might be to fix the actual problem. i.e., reduced labor or waived labor. I know that is the case with my dealer. It doesn't cost to ask.

Paul

They called me and told me it was the right front caliber seal the caliber was locking up and from reading online the O2 sensor has nothing to do with that when I went in i asked him if the o2 was the cause of the problem 3 times and he assured it was so i told him just now they need to figure out what to do because they fixed the wrong problem. I am on limited funds and told them the o2 sensor could have been fixed at a later time this was a problem that needed to be fixed asap. I feel like they should fix it for free since they didnt fix the problem I came in for. But i dont know if that will work. In the meantime I will use there loaner a bad a** 2011 RX until they figure out what to do!

Link to comment
Share on other sites

So I know nothing about cars I'm not gonna lie my car 2 weeks ago started loosing power slowly and then the steering wheel would shake really bad I would also have a burning smell coming from the hood the car would also feel like it was loosing power. I took it into a shop they thought it was the serpentine belt but after checking everything 2 times found nothing wrong with the car. i took it the following week after it did it again to the lexus dealership they said it was my o2 sensor and charged me 450 bucks to get it fixed saying it was the problem. okay so that was 2 weeks ago for the pass 3 days my car has been doing it again it will do it when my car stays at about 45mph to 50 steady. If i slow down or stop at a red light and go again it stops for a little bit then starts once i am at a steady 45 50. Any ideas? I dont believe it was the o2 sensor and dont feel that they fixed the right problem and now they said to bring it back in and I know they will charge me alot more again to fix the problem i specifically wanted fixed in the first place. Please help! btw its a gs300 with 107k

TA makes some good points. The only thing I would add is that since you paid for a problem that was not fixed, the dealership should cover some of whatever cost there might be to fix the actual problem. i.e., reduced labor or waived labor. I know that is the case with my dealer. It doesn't cost to ask.

Paul

They called me and told me it was the right front caliber seal the caliber was locking up and from reading online the O2 sensor has nothing to do with that when I went in i asked him if the o2 was the cause of the problem 3 times and he assured it was so i told him just now they need to figure out what to do because they fixed the wrong problem. I am on limited funds and told them the o2 sensor could have been fixed at a later time this was a problem that needed to be fixed asap. I feel like they should fix it for free since they didnt fix the problem I came in for. But i dont know if that will work. In the meantime I will use there loaner a bad a** 2011 RX until they figure out what to do!

IMO, you did the right thing and took the right approach. Stick to your position.

Paul

Link to comment
Share on other sites


Thank Paul :-) hopefully they fix this I am ready to trade the thing in !

So I know nothing about cars I'm not gonna lie my car 2 weeks ago started loosing power slowly and then the steering wheel would shake really bad I would also have a burning smell coming from the hood the car would also feel like it was loosing power. I took it into a shop they thought it was the serpentine belt but after checking everything 2 times found nothing wrong with the car. i took it the following week after it did it again to the lexus dealership they said it was my o2 sensor and charged me 450 bucks to get it fixed saying it was the problem. okay so that was 2 weeks ago for the pass 3 days my car has been doing it again it will do it when my car stays at about 45mph to 50 steady. If i slow down or stop at a red light and go again it stops for a little bit then starts once i am at a steady 45 50. Any ideas? I dont believe it was the o2 sensor and dont feel that they fixed the right problem and now they said to bring it back in and I know they will charge me alot more again to fix the problem i specifically wanted fixed in the first place. Please help! btw its a gs300 with 107k

TA makes some good points. The only thing I would add is that since you paid for a problem that was not fixed, the dealership should cover some of whatever cost there might be to fix the actual problem. i.e., reduced labor or waived labor. I know that is the case with my dealer. It doesn't cost to ask.

Paul

They called me and told me it was the right front caliber seal the caliber was locking up and from reading online the O2 sensor has nothing to do with that when I went in i asked him if the o2 was the cause of the problem 3 times and he assured it was so i told him just now they need to figure out what to do because they fixed the wrong problem. I am on limited funds and told them the o2 sensor could have been fixed at a later time this was a problem that needed to be fixed asap. I feel like they should fix it for free since they didnt fix the problem I came in for. But i dont know if that will work. In the meantime I will use there loaner a bad a** 2011 RX until they figure out what to do!

IMO, you did the right thing and took the right approach. Stick to your position.

Paul

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership