Do Not Sell My Personal Information Jump to content

Problem With 93 Lexus Es 300


TheKlone
 Share

Recommended Posts

Ok first want to know is there anyway to raise my shocks on my back tires

Another problem is my rpm gauge no long workers but speedometer works

Also where do I bu the plastic clips that hold my panels up inside the car I also have a few missing in the trunk. I hope somebody can help me

Link to comment
Share on other sites


Hi,

Sounds like you should replace rear struts, unless you want it to be a higher than usual ride, then I'm useless.

I'm not exactly sure how the tach gets signals but I bet it's from the computer. May just be a bad wire or connector. The other prob may be that you need a new tach, and I'd get a used cluster from the yanker yard, once you check on the line continuity.

Plastic clips can be had at a yanker yard too, or most auto stores and hardware stores carry many different types of clips.

LL

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership