Do Not Sell My Personal Information Jump to content

04 Rx330 Navigation Problem.


LexusGT
 Share

Recommended Posts

04 RX330 w/ 115,000 miles.

Navigation w/out Mark Levinson.

On navigation screen, it displays "Error: System unable to access the problem" "Incorrect program disk. Please insert proper disk."

I just change car battery and Navigation doesn't work. It worked fine.

I tried remove the disk and reinsert from the back but didnt't work.

Thank you for your advice in advance !

Link to comment
Share on other sites


That doesn't sound good! :unsure: May want to try checking your fuses...the unit must be getting power though if it was ejecting the disk...so the fuses would be a long shot.

You may need to contact the dealer...on this one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership