Do Not Sell My Personal Information Jump to content

Instrument Panel


odsalman
 Share

Recommended Posts

hi new to this forum,

I have a 56plate IS220D. It has not been a reliable car for me and now I have switched on the engine today and the middle instrument panel is completely dead and does not light up or work. this is the radio and heating system. the cd works but does not play as no sound etc. I have a parrot hands free kit wired up to the sound system and this work fine

the obvious place to check is the fuses? I have looked and each fuse shows no breaks.

Any suggestions ?

Link to comment
Share on other sites


This being U.S. part of the forum there is little information specific to the diesel IS sold in the U.K. Have you checked the larger higher amperage fuses in the engine compartment fuse box? On U.S. models, some of the high amperage fuses control whole systems and the low amperage small fuses are more like "sub-fuses". And you could pull the fuse box (after disconnecting the car battery) and check for corrosion.

"56plate" doesn't mean anything here in the U.S. since our plates are not tied to year - I looked it up and am assuming "2006".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership