Sign in to follow this  
GeeBoy

Brake Light Issues

Recommended Posts

I recently purchased a 93 SC400 and the brake lights dont turn on when I turn on my headlights. They come on when I brake but not when im driving regularly at night. I changed the tail lights thinking that one of the filaments was burnt out but no success. I also checked the fuses which seem to be fine so I am mind-*BLEEP*ed right now. If you folks can help me out I would appreciate it. Thanks

Share this post


Link to post
Share on other sites

Have you tried using a basic test light to see if power is getting to the taillight pin of the bulb sockets? If power is getting to the tail light pin in the bulb sockets, the problem is likely a bad ground and you would then check the ground wire connections in the trunk.

Share this post


Link to post
Share on other sites

No i did not try that yet. Thanks for the input. Im used to having things just work but this project car is really keeping me busy.

Share this post


Link to post
Share on other sites

Yesssss!!!!! Finally found out the issue. For some dumb reason the previous owners removed a relay controlling the lights from the kick panel. Restored functionality to tail lights sidemarkers and corner lights. Thanks to all those who gave me tips.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this